Project

General

Profile

Bug #16216

Bootdisk based imaging uses the primary interface instead of the provisioning interface

Added by Dylan Baars about 6 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Using latest version of Katello, with boot disk based imaging for VMware. I am attempting to build a VM in our DMZ with two interfaces, one that points internal and one that is an external IP exposed to the internet

When building a new host via Hosts > New Host, it is possible to add multiple network interfaces and specific a "provisioning interface" (in my case, the 'internal' interface) and a "primary interface" (the external one)
When the VM is created, it attempts to boot using the provisioning interface - great! However, it cannot find the kickstart template (screenshot attached - "connection_timeout.jpg"). Using the spoof address to check where the kickstart is, it is assigned to the primary interface IP address

http://wellkatello.niwa.local/unattended/provision?spoof=103.229.249.7

I think this should be the provisioning interface

I have attached screenshots of the interface configuration for both

connection_timeout.jpg View connection_timeout.jpg 134 KB Dylan Baars, 08/21/2016 07:36 PM
external_interface_primary.JPG View external_interface_primary.JPG 56.8 KB Dylan Baars, 08/21/2016 07:43 PM
internal_inteface_provisioning.JPG View internal_inteface_provisioning.JPG 59 KB Dylan Baars, 08/21/2016 07:43 PM
Connection timeout External interface primary Internal inteface provisioning

History

#1 Updated by Justin Sherrill about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 143 to 184

#2 Updated by Justin Sherrill almost 6 years ago

  • Project changed from Katello to Boot disk
  • Category deleted (Hosts)

Moving this to the bootdisk plugin

#3 Updated by Dominic Cleal almost 6 years ago

  • Status changed from New to Need more information

The IP address isn't used in the URL, so I'm unsure of the relevance of that. The screenshot of the host shows that it's configuring the provisioning interface IP address. The screenshot also shows a timeout which is probably caused by a networking issue, ensure every detail in the provided DHCP lease is correct.

If the request is logged then please provide it, else if it isn't logged then it's likely that networking isn't set up correctly as the request isn't received by Foreman.

#4 Updated by Anonymous over 5 years ago

  • Status changed from Need more information to Resolved

no reaction, closing.

#5 Updated by Greg Sutcliffe about 4 years ago

  • Target version deleted (Katello 3.1.1)

Also available in: Atom PDF