Project

General

Profile

Bug #16252

katello-installer --reset does not ask for confirmation

Added by Stephen Benjamin almost 6 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1341216
Description of problem:

The command "satellite-installer --reset" just runs without asking for a confirmation.

Version-Release number of selected component (if applicable):

Sat 6.2 snap 13

How reproducible:

always

Steps to Reproduce:
1. In satellite machine console
2. run "satellite-installer --reset"

Actual results:

System reset is performed successfully but without asking for confirmation

Expected results:

A message:

$ satellite-installer --reset
Are you sure you want to reset your satellite system? [Y/n]

or

$ satellite-installer --reset -y
resetting..... (no confirmation needed because of -y)

Associated revisions

Revision 56179358 (diff)
Added by Chris Roberts over 5 years ago

Fixes #16252 - add check to reset hook

Fixes #16252 - add check to reset hook

Fixes #16252 - add check to reset hook

Fixes #16252 - add check to reset hook

Fixes #16252 - add check to reset hook

Fixes #16252 - add check to reset hook

Fixes #16252 - add check to reset hook

History

#1 Updated by Justin Sherrill almost 6 years ago

  • Subject changed from satellite-installer --reset does not ask for confirmation to katello-installer --reset does not ask for confirmation
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Chris Roberts over 5 years ago

  • Assignee set to Chris Roberts
  • Target version set to 133
  • Legacy Backlogs Release (now unused) changed from 114 to 197
  • Difficulty set to easy

#3 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/424 added

#4 Updated by Chris Roberts over 5 years ago

  • Target version changed from 133 to 140

#5 Updated by Chris Roberts over 5 years ago

  • Status changed from Ready For Testing to Resolved

Also available in: Atom PDF