Project

General

Profile

Bug #1634

Report filter does not work

Added by Adam Kosmin about 10 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Reporting
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

debian squeeze package 0.4.2-1 installed

In "reports", the log filter does not work when attempting to display anything other than "all messages".

Associated revisions

Revision 94f61f7b (diff)
Added by Ohad Levy almost 10 years ago

make sure that info messages are not shown when filtering is enabled refs #1634

History

#1 Updated by Ohad Levy about 10 years ago

  • Status changed from New to Need more information

can you provide an example of what is not working, and how should it work?

thanks

#2 Updated by Adam Kosmin about 10 years ago

I'm not sure what else can be said other than the filter displayed in the reports section doesn't work. Anything other than "all messages" fails.

#3 Updated by Ohad Levy about 10 years ago

you mean that the auto completer does not work? (e.g. it does not suggest values?)

does the search work? e.g. if you manually input log ~ package or something like that?

#4 Updated by Josh Baird about 10 years ago

1. From "Hosts," click on a host.
2. On the host properties page, click "Reports"
3. Click on a report that had an error.
4. Change the "Show Log Messages" dropdown to "Errors Only" or "Warnings Or Errors"

While the filter does show errors only, or warnings/errors, it also shows "info" reports. This may the intention of this function, though. I don't mind it.

#5 Updated by Adam Kosmin about 10 years ago

That's a strange thing to "not mind" considering the purpose of a filter. I'd expect a selection of "Errors Only" to result in a page with only errors shown.

Thanks again

#6 Updated by Ohad Levy about 10 years ago

Thats exactly how it works for me, if I click on errors, then i only see errors.

do you happen to have a javascript error (maybe in your browser console)?

#7 Updated by Benjamin Papillon about 9 years ago

  • Status changed from Need more information to Feedback

Hello,

Do still have the issue?

#8 Updated by Stephen Benjamin almost 8 years ago

  • Bugzilla link set to 1126938

#9 Updated by Anonymous about 5 years ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved

no reaction, closing.

Also available in: Atom PDF