Project

General

Profile

Bug #16344

Unable to upload large RPM files from Satellite UI

Added by Partha Aji almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191395
Description of problem:
Unable to upload large RPM files from Satellite UI. Uploading the files gives the following error message.

[Thu Jan 15 10:10:26 2015] [error] [client 10.167.221.28] request body exceeds maximum size (16777216) for SSL buffer, referer: https://jxn-lx-rhsatp01.hbc.com/products/48/repositories/259
[Thu Jan 15 10:10:26 2015] [error] [client 10.167.221.28] could not buffer message body to allow SSL renegotiation to proceed, referer: https://jxn-lx-rhsatp01.hbc.com/products/48/repositories/259
[Thu Jan 15 10:18:06 2015] [error] [client 10.167.221.28] Re-negotiation handshake failed: Not accepted by client!?, referer: https://jxn-lx-rhsatp01/products
Version-Release number of selected component (if applicable):
Satellite v6.0.7
How reproducible:
Always
Steps to Reproduce:
1. Login to Satellite WEB UI.
2. Go to Products
3. New Product (Give it a name and save it)
4. Create a new Repo (Give it a name, set type to yum and save it)
5. Under the product you created earlier, select the Repositories Tab and click Browse. Select a file that is around 100MB or bigger and click upload.
6. After a while, the package will stop uploading and no errors will be displayed in UI.
7. The error will be displayed in the logs.
Actual results:
Getting the below error message in logs:
[Thu Jan 15 10:10:26 2015] [error] [client 10.167.221.28] request body exceeds maximum size (16777216) for SSL buffer, referer: https://jxn-lx-rhsatp01.hbc.com/products/48/repositories/259
[Thu Jan 15 10:10:26 2015] [error] [client 10.167.221.28] could not buffer message body to allow SSL renegotiation to proceed, referer: https://jxn-lx-rhsatp01.hbc.com/products/48/repositories/259
[Thu Jan 15 10:18:06 2015] [error] [client 10.167.221.28] Re-negotiation handshake failed: Not accepted by client!?, referer: https://jxn-lx-rhsatp01/products
Expected results:
Large RPM files should be uploaded.
Additional info:
I attempted to increase SSLRenegBufferSize to 300 MB in /etc/httpd/conf.d/05-foreman-ssl.d/katello.conf , but the upload still fails after a certain amount of time.
There is no error reported in the UI. It looks like it's not transferring though by using iftop. The following error occurs in the foreman-ssl_error_ssl.log:
Fri Feb 06 10:22:47 2015] [error] [client *] request body exceeds maximum size (209715200) for SSL buffer, referer: https://jxn-lx-rhsatp01.hbc.com/products/48/repositories/259
[Fri Feb 06 10:22:47 2015] [error] [client *] could not buffer message body to allow SSL renegotiation to proceed, referer: https://jxn-lx-rhsatp01.hbc.com/products/48/repositories/259
It appears that Satellite might not be handling a HTTP 1.1 Expect header correctly.

Subtasks


Related issues

Has duplicate Katello - Bug #16224: No error is displayed to user when uploading files that are too bigDuplicate2016-08-22
Blocked by Bastion - Feature #16296: Update ng-upload temporarily to pass content to errorCatcherClosed2016-08-25

Associated revisions

Revision 0127b0ad (diff)
Added by David Davis almost 3 years ago

Fixes #16344 - Show error when content is too big (#6290)

When you upload a file that's too big, you currently don't get an error
message. This fixes that and properly shows an error message.

History

#1 Updated by David Davis almost 3 years ago

  • Blocked by Feature #16296: Update ng-upload temporarily to pass content to errorCatcher added

#2 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6290 added

#3 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Justin Sherrill almost 3 years ago

  • Subject changed from Unable to upload large RPM files from Satellite UI to Unable to upload large RPM files from Satellite UI
  • Legacy Backlogs Release (now unused) set to 162
  • Difficulty set to medium

#5 Updated by David Davis almost 3 years ago

  • Has duplicate Bug #16224: No error is displayed to user when uploading files that are too big added

Also available in: Atom PDF