Project

General

Profile

Bug #16362

foreman-discovery still uses attr_accessible

Added by Lukas Pramuk about 5 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

After plugin enablement the webapp is broken, katello not running...

(x) Web application could not be started

Host::Managed is using attr_accessible so must either be converted to strong parameters, or add the protected_attributes gem (RuntimeError)
/usr/share/foreman/config/initializers/active_record_extensions.rb:21:in `attr_accessible'
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_discovery-5.0.2/app/models/host/managed_extensions.rb:15:in `block in <module:ManagedExtensions>'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/concern.rb:120:in `class_eval'
/opt/rh/sclo-ror42/root/usr/share/gems/gems/activesupport-4.2.5.1/lib/active_support/concern.rb:120:in `append_features'
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_discovery-5.0.2/lib/foreman_discovery/engine.rb:170:in `include'
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_discovery-5.0.2/lib/foreman_discovery/engine.rb:170:in `block in <class:Engine>'

Related to #15741
It looks like foreman-discovery reqiures similar changes as well.


Related issues

Has duplicate Discovery - Refactor #15750: Add strong parameters to Discovery PluginClosed2016-07-20

History

#1 Updated by Lukas Pramuk about 5 years ago

tfm-rubygem-foreman_discovery-5.0.2-1.fm1_12.el7.noarch

foreman-1.13.0-0.develop.201608221148git5908bf4.el7.noarch
foreman-installer-1.13.0-0.develop.201608290324gitad62114.el7.noarch
katello-3.1.0-4.nightly.el7.noarch

#2 Updated by Lukas Pramuk about 5 years ago

Duplicate of #15750

Again we have yet another merged but not packaged changeset.

#3 Updated by Lukas Pramuk about 5 years ago

let use this duplicate issue to track down foreman-discovery plugin is packaged being foreman1.13 compatible.

Title: build foreman-discovery plugin being foreman1.13 compatible

#4 Updated by Lukas Zapletal about 5 years ago

  • Has duplicate Refactor #15750: Add strong parameters to Discovery Plugin added

#5 Updated by Lukas Zapletal about 5 years ago

  • Status changed from New to Duplicate

Thank you, there are two more patches to go and then I will make new nightly: #15750 and #12634.

#6 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF