Project

General

Profile

Bug #16376

required flag not set from puppetclass

Added by Ori Rabin almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Parameters
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Steps:
1) Go to Configure -> Classes
2) Edit a puppetclass
3) Find an overridden parameter and set it to require then save
4) Edit the class again and check the required flag

The flag isn't set.

Workaround: go to Configure -> Smart class parameters and edit the parameter from there.


Related issues

Related to Foreman - Feature #3917: Add strong_parameters to foremanClosed2013-12-19

Associated revisions

Revision ddf80e13 (diff)
Added by Dominic Cleal almost 4 years ago

fixes #16376 - use correct params filter for nested Puppet LKs

History

#1 Updated by Dominic Cleal almost 4 years ago

  • Related to Feature #3917: Add strong_parameters to foreman added

#2 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 160

#3 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#4 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3793 added

#5 Updated by Dominic Cleal almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF