Project

General

Profile

Bug #16461

Role filter is not overriding from CLI and API

Added by Jitendra Yejare almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Users, Roles and Permissions
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1373840
Description of problem:
According to new feature Canned Role:Org Admin, The user should be able to override the taxonomies of role filter over role taxonomies.
The behavior is expected from UI, but not from hammer CLI and API. I am unable to override the taxonomies of role filter. The CLI says it does overrided the role filter and API says 200 OK result but the override is not actually happening. In short the results from API and CLI are false positive.

Version-Release number of selected component (if applicable):
foreman-1.13.0-0.develop.201609051301git713be41.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a role with taxonomies.
2. Create/(Update existing) filter in above role with overridden taxonomies from CLI/API.
3. Verify if role filter is created/Updated with taxonomies.

Actual results:
Role filter is not overriding from CLI and API.

Expected results:
The role filter should be able to override from CLI and API.

Additional info:


Related issues

Related to Foreman - Feature #7806: As a user, I would like roles to associate roles with organizations.Closed2014-10-03
Related to Foreman - Bug #17107: Expose override attribute in filter API outputClosed2016-10-26

Associated revisions

Revision 9bdc4fea (diff)
Added by Marek Hulán almost 4 years ago

Fixes #16461 - expose override in filter API

Revision 4132ff87 (diff)
Added by Marek Hulán almost 4 years ago

Fixes #16461 - expose override in filter API

(cherry picked from commit 9bdc4fea9711290431b611337ac72c2003dc8efd)

History

#1 Updated by Marek Hulán almost 4 years ago

  • Category set to Users, Roles and Permissions

#2 Updated by Marek Hulán almost 4 years ago

  • Related to Feature #7806: As a user, I would like roles to associate roles with organizations. added

#3 Updated by Marek Hulán almost 4 years ago

  • Target version set to 1.5.3
  • Legacy Backlogs Release (now unused) set to 160

The override flag should be exposed in API, since the feature was introduced in 1.13 I'm aligning this to the same version.

#4 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3822 added

#5 Updated by Marek Hulán almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Marek Hulán almost 4 years ago

  • Related to Bug #17107: Expose override attribute in filter API output added

Also available in: Atom PDF