Project

General

Profile

Bug #16482

Nightly install on rhel6 failed with dependcies issue

Added by Sachin Ghai over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I was trying to install nightly on rhel6.8 with katello-deploy and installation failed with dependency issues:

--> Processing Dependency: foreman >= 1.11.0 for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
--> Processing Dependency: tfm-rubygem(rest-client) for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
--> Processing Dependency: tfm-rubygem(rabl) for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
--> Processing Dependency: tfm-rubygem(oauth) for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
--> Processing Dependency: tfm-rubygem(jquery-ui-rails) for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
--> Processing Dependency: tfm-rubygem(gettext_i18n_rails) for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
--> Processing Dependency: foreman-postgresql for package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch
---> Package tfm-rubygem-runcible.noarch 0:1.8.0-1.el6 will be installed
--> Processing Dependency: tfm-rubygem(rest-client) < 2.0.0 for package: tfm-rubygem-runcible-1.8.0-1.el6.noarch
--> Processing Dependency: tfm-rubygem(rest-client) >= 1.6.1 for package: tfm-rubygem-runcible-1.8.0-1.el6.noarch
--> Processing Dependency: sclo-ror42-rubygem(i18n) >= 0.5.0 for package: tfm-rubygem-runcible-1.8.0-1.el6.noarch
--> Processing Dependency: sclo-ror42-rubygem(activesupport) >= 3.0.10 for package: tfm-rubygem-runcible-1.8.0-1.el6.noarch
--> Processing Dependency: tfm-rubygem(oauth) for package: tfm-rubygem-runcible-1.8.0-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: sclo-ror42-rubygem(i18n) >= 0.5.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(deface) < 2.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(oauth)
Error: Package: katello-debug-3.1.0-4.nightly.el6.noarch (katello)
           Requires: foreman-debug
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(angular-rails-templates) >= 0.0.4
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: sclo-ror42-rubygem(activesupport) >= 3.0.10
Error: Package: katello-installer-base-3.2.0-1.nightly.201608302211gitd696e2e.el6.noarch (katello)
           Requires: foreman-proxy
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman) < 1.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: foreman-postgresql
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman_tasks) >= 0.0.3
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(foreman_docker) >= 0.2.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(jquery-ui-rails)
Error: Package: katello-installer-base-3.2.0-1.nightly.201608302211gitd696e2e.el6.noarch (katello)
           Requires: foreman-installer >= 1.11.0
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: tfm-rubygem(rest-client) < 2.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(bastion) >= 3.0.0
Error: Package: katello-common-3.1.0-4.nightly.el6.noarch (katello)
           Requires: tfm-rubygem-hammer_cli_foreman
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman_docker)
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(foreman-tasks) < 0.8.0
Error: Package: tfm-rubygem-hammer_cli_import-0.11.2-1.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli) >= 0.1.3
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(rest-client)
Error: Package: katello-selinux-3.0.1-1.el6.noarch (katello)
           Requires: foreman-selinux >= 1.8
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman) >= 0.5.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(deface) >= 1.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(rabl)
Error: Package: tfm-rubygem-hammer_cli_import-0.11.2-1.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman)
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(gettext_i18n_rails)
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman_bootdisk)
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(foreman-tasks) >= 0.7.1
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: tfm-rubygem(rest-client) >= 1.6.1
Error: Package: katello-common-3.1.0-4.nightly.el6.noarch (katello)
           Requires: tfm-rubygem-hammer_cli
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: tfm-rubygem(oauth)
Error: Package: tfm-rubygem-anemone-0.7.2-14.el6.noarch (katello)
           Requires: sclo-ror42-rubygem(nokogiri) >= 1.3.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(bastion) < 4.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(apipie-rails) >= 0.1.1
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: foreman >= 1.11.0
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: sclo-ror42-rubygem(i18n) >= 0.5.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(deface) < 2.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(oauth)
Error: Package: katello-debug-3.1.0-4.nightly.el6.noarch (katello)
           Requires: foreman-debug
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(angular-rails-templates) >= 0.0.4
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: sclo-ror42-rubygem(activesupport) >= 3.0.10
Error: Package: katello-installer-base-3.2.0-1.nightly.201608302211gitd696e2e.el6.noarch (katello)
           Requires: foreman-proxy
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman) < 1.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: foreman-postgresql
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman_tasks) >= 0.0.3
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(foreman_docker) >= 0.2.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(jquery-ui-rails)
Error: Package: katello-installer-base-3.2.0-1.nightly.201608302211gitd696e2e.el6.noarch (katello)
           Requires: foreman-installer >= 1.11.0
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: tfm-rubygem(rest-client) < 2.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(bastion) >= 3.0.0
Error: Package: katello-common-3.1.0-4.nightly.el6.noarch (katello)
           Requires: tfm-rubygem-hammer_cli_foreman
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman_docker)
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(foreman-tasks) < 0.8.0
Error: Package: tfm-rubygem-hammer_cli_import-0.11.2-1.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli) >= 0.1.3
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(rest-client)
Error: Package: katello-selinux-3.0.1-1.el6.noarch (katello)
           Requires: foreman-selinux >= 1.8
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman) >= 0.5.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(deface) >= 1.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(rabl)
Error: Package: tfm-rubygem-hammer_cli_import-0.11.2-1.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman)
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(gettext_i18n_rails)
Error: Package: tfm-rubygem-hammer_cli_katello-0.0.26-1.201608222034git14c9676.el6.noarch (katello)
           Requires: tfm-rubygem(hammer_cli_foreman_bootdisk)
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(foreman-tasks) >= 0.7.1
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: tfm-rubygem(rest-client) >= 1.6.1
Error: Package: katello-common-3.1.0-4.nightly.el6.noarch (katello)
           Requires: tfm-rubygem-hammer_cli
Error: Package: tfm-rubygem-runcible-1.8.0-1.el6.noarch (katello)
           Requires: tfm-rubygem(oauth)
Error: Package: tfm-rubygem-anemone-0.7.2-14.el6.noarch (katello)
           Requires: sclo-ror42-rubygem(nokogiri) >= 1.3.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(bastion) < 4.0.0
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: tfm-rubygem(apipie-rails) >= 0.1.1
Error: Package: tfm-rubygem-katello-3.2.0-.201608012310gitad757231.nightly.el6.noarch (katello)
           Requires: foreman >= 1.11.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
WARNING: Skipping installer command: foreman-installer --scenario katello

History

#1 Updated by Justin Sherrill over 5 years ago

  • Category set to Installer
  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

This is because foreman is not producing el6 builds. They will no longer be producing el6 builds in nightly.

Also available in: Atom PDF