Project

General

Profile

Bug #16524

katello-agent 2.6.0 not installable on rhel5

Added by Daniel Kimsey almost 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Client/Agent
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Installing katello-agent on RHEL5 x86_64 fails with a dependency errors. I used the repo:

[root@port-db-dv3-01 ~]# yum install katello-agent
Loaded plugins: downloadonly, kmod, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
katello-client                                                                                                                                               | 3.1 kB     00:00
katello-client/primary_db                                                                                                                                    |  10 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package katello-agent.noarch 0:2.6.0-2.el5 set to be updated
--> Processing Dependency: python-pulp-agent-lib >= 2.6 for package: katello-agent
--> Processing Dependency: python-gofer-proton >= 2.5 for package: katello-agent
--> Processing Dependency: pulp-rpm-handlers >= 2.6 for package: katello-agent
--> Processing Dependency: gofer >= 2.5 for package: katello-agent
--> Processing Dependency: yum-plugin-security for package: katello-agent
--> Running transaction check
---> Package gofer.noarch 0:2.7.5-1.el5 set to be updated
--> Processing Dependency: python-gofer = 2.7.5 for package: gofer
---> Package katello-agent.noarch 0:2.6.0-2.el5 set to be updated
--> Processing Dependency: yum-plugin-security for package: katello-agent
---> Package pulp-rpm-handlers.noarch 0:2.8.0-0.7.beta.el5 set to be updated
--> Processing Dependency: python-pulp-rpm-common = 2.8.0 for package: pulp-rpm-handlers
---> Package python-gofer-proton.noarch 0:2.7.5-1.el5 set to be updated
--> Processing Dependency: python-qpid-proton >= 0.9-5 for package: python-gofer-proton
---> Package python-pulp-agent-lib.noarch 0:2.8.0-0.7.beta.el5 set to be updated
--> Processing Dependency: python-pulp-common = 2.8.0 for package: python-pulp-agent-lib
--> Running transaction check
---> Package katello-agent.noarch 0:2.6.0-2.el5 set to be updated
--> Processing Dependency: yum-plugin-security for package: katello-agent
---> Package python-gofer.noarch 0:2.7.5-1.el5 set to be updated
--> Processing Dependency: python-uuid for package: python-gofer
--> Processing Dependency: python-ctypes for package: python-gofer
---> Package python-gofer-proton.noarch 0:2.7.5-1.el5 set to be updated
--> Processing Dependency: python-qpid-proton >= 0.9-5 for package: python-gofer-proton
---> Package python-pulp-common.noarch 0:2.8.0-0.7.beta.el5 set to be updated
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-common
---> Package python-pulp-rpm-common.noarch 0:2.8.0-0.7.beta.el5 set to be updated
--> Running transaction check
---> Package katello-agent.noarch 0:2.6.0-2.el5 set to be updated
--> Processing Dependency: yum-plugin-security for package: katello-agent
---> Package python-ctypes.x86_64 0:1.0.2-3.el5 set to be updated
---> Package python-gofer-proton.noarch 0:2.7.5-1.el5 set to be updated
--> Processing Dependency: python-qpid-proton >= 0.9-5 for package: python-gofer-proton
---> Package python-isodate.noarch 0:0.5.0-4.pulp.el5 set to be updated
---> Package python-uuid.noarch 0:1.30-3.el5 set to be updated
--> Finished Dependency Resolution
python-gofer-proton-2.7.5-1.el5.noarch from katello-client has depsolving problems
  --> Missing Dependency: python-qpid-proton >= 0.9-5 is needed by package python-gofer-proton-2.7.5-1.el5.noarch (katello-client)
katello-agent-2.6.0-2.el5.noarch from katello-client has depsolving problems
  --> Missing Dependency: yum-plugin-security is needed by package katello-agent-2.6.0-2.el5.noarch (katello-client)
Error: Missing Dependency: python-qpid-proton >= 0.9-5 is needed by package python-gofer-proton-2.7.5-1.el5.noarch (katello-client)
Error: Missing Dependency: yum-plugin-security is needed by package katello-agent-2.6.0-2.el5.noarch (katello-client)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@port-db-dv3-01 ~]# yum info katello-agent
Loaded plugins: downloadonly, kmod, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
spacewalk-client                                                                                                                                             | 2.1 kB     00:00
Available Packages
Name       : katello-agent
Arch       : noarch
Version    : 2.6.0
Release    : 2.el5
Size       : 27 k
Repo       : katello-client
Summary    : The Katello Agent
URL        : https://github.com/Katello/katello-agent
License    : LGPLv2
Description: Provides plugin for gofer, which allows communicating with Katello server
           : and execute scheduled actions.

Associated revisions

Revision 2938192f (diff)
Added by Justin Sherrill almost 6 years ago

Fixes #16524 - use yum-security for el5

Revision 070f1bdd
Added by Justin Sherrill almost 6 years ago

Merge pull request #286 from jlsherrill/16524

Fixes #16524 - use yum-security for el5

History

#1 Updated by Justin Sherrill almost 6 years ago

  • Project changed from Foreman to Katello
  • Category changed from 47 to Client/Agent
  • Assignee set to Justin Sherrill
  • Target version set to 126
  • Legacy Backlogs Release (now unused) set to 184
  • Difficulty set to trivial

#2 Updated by The Foreman Bot almost 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-packaging/pull/286 added

#3 Updated by Daniel Kimsey almost 6 years ago

FWIW the pull request looks sane. Should address the yum-plugin-security issue.

The second dependency on python-gofer-proton packages will also need to be added to the katello client el5 repository.

#4 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF