Project

General

Profile

Actions

Feature #16630

closed

Need a way to extend existing apipie specification

Added by Marek Hulán over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
API
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description


Related issues 6 (2 open4 closed)

Related to Katello - Feature #14762: hammer cannot manipulate content source on hosts.Duplicate04/21/2016Actions
Related to Foreman - Feature #3763: Ability for engine/plugin to extend RABL responsesClosedTimo Goebel11/26/2013Actions
Related to Foreman - Bug #17678: API-doc : Create a compute resource - URL param description missing "docker and rackspace"ClosedSwapnil Abnave12/15/2016Actions
Related to OpenSCAP - Bug #16490: API lacks ability to modify/specify hostgroup openscap capsule via API or hammer cliClosedMarek Hulán09/08/2016Actions
Blocks Docker - Bug #12116: `hammer compute-resource create -h` do not mention DockerNew10/08/2015Actions
Blocks Katello - Bug #16812: Replace controller extensions with apipie extensionsAssigned10/05/2016Actions
Actions #1

Updated by Marek Hulán over 7 years ago

  • Blocks Bug #16490: API lacks ability to modify/specify hostgroup openscap capsule via API or hammer cli added
Actions #2

Updated by Ivan Necas over 7 years ago

  • Target version changed from 113 to 1.5.1
Actions #3

Updated by Ivan Necas over 7 years ago

  • Blocks Bug #12116: `hammer compute-resource create -h` do not mention Docker added
Actions #4

Updated by Justin Sherrill over 7 years ago

  • Related to Bug #16812: Replace controller extensions with apipie extensions added
Actions #5

Updated by Justin Sherrill over 7 years ago

  • Related to deleted (Bug #16812: Replace controller extensions with apipie extensions)
Actions #6

Updated by Justin Sherrill over 7 years ago

  • Blocks Bug #16812: Replace controller extensions with apipie extensions added
Actions #7

Updated by Ivan Necas over 7 years ago

  • Target version changed from 1.5.1 to 1.4.1
Actions #8

Updated by Marek Hulán over 7 years ago

  • Related to Feature #14762: hammer cannot manipulate content source on hosts. added
Actions #9

Updated by Dominic Cleal over 7 years ago

  • Is duplicate of Feature #3763: Ability for engine/plugin to extend RABL responses added
Actions #10

Updated by Dominic Cleal over 7 years ago

  • Status changed from New to Duplicate

#3763 seems to describe this.

Actions #11

Updated by Marek Hulán over 7 years ago

I think RABL templates are separate issue... Anyway, I've updated all issues that were blocked on this to be blocked on the new one and I hope Ivan will pull that into his target version too.

Actions #12

Updated by Ivan Necas over 7 years ago

  • Target version changed from 1.4.1 to 1.3.2
Actions #13

Updated by Ivan Necas over 7 years ago

  • Status changed from Duplicate to New

I don't think this is a duplicate of #3763

Actions #14

Updated by Ivan Necas over 7 years ago

  • Is duplicate of deleted (Feature #3763: Ability for engine/plugin to extend RABL responses)
Actions #15

Updated by Ivan Necas over 7 years ago

  • Related to Feature #3763: Ability for engine/plugin to extend RABL responses added
Actions #16

Updated by Marek Hulán about 7 years ago

  • Blocks Bug #17678: API-doc : Create a compute resource - URL param description missing "docker and rackspace" added
Actions #17

Updated by Dominic Cleal about 7 years ago

  • Blocks deleted (Bug #17678: API-doc : Create a compute resource - URL param description missing "docker and rackspace")
Actions #18

Updated by Dominic Cleal about 7 years ago

  • Related to Bug #17678: API-doc : Create a compute resource - URL param description missing "docker and rackspace" added
Actions #19

Updated by Ivan Necas almost 7 years ago

  • Target version changed from 1.3.2 to 1.13.3
Actions #20

Updated by Ivan Necas over 6 years ago

  • Target version changed from 1.13.3 to 1.17.1
Actions #21

Updated by Ivan Necas over 6 years ago

  • Status changed from New to Ready For Testing
  • Target version changed from 1.17.1 to 1.18.0-RC1
  • Pull request https://github.com/Apipie/apipie-rails/pull/554 added
Actions #22

Updated by Marek Hulán over 6 years ago

  • Blocks deleted (Bug #16490: API lacks ability to modify/specify hostgroup openscap capsule via API or hammer cli)
Actions #23

Updated by Marek Hulán over 6 years ago

  • Related to Bug #16490: API lacks ability to modify/specify hostgroup openscap capsule via API or hammer cli added
Actions #24

Updated by Ivan Necas over 6 years ago

  • Status changed from Ready For Testing to Closed

Fixed in apipie-rails-0.5.2

Actions

Also available in: Atom PDF