Project

General

Profile

Bug #16653

Connection errors on capsule install

Added by John Mitsch almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Katello 3.2 RC1

[ERROR 2016-09-21 10:22:30 main] Proxy pipeline-capsule-3-2-centos7.example.com cannot be registered: Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([Errno::ECONNREFUSED]: Connection refused - connect(2) for "pipeline-capsule-3-2-centos7.example.com" port 9090) for proxy https://pipeline-capsule-3-2-centos7.example.com:9090/features Please check the proxy is configured and running on the host.

logs attached, to reproduce, install a capsule normally

capsule_error.log capsule_error.log 9.43 KB John Mitsch, 09/22/2016 08:48 AM

History

#1 Updated by Justin Sherrill almost 3 years ago

  • Category set to Foreman Proxy Content
  • Legacy Backlogs Release (now unused) set to 162

#2 Updated by Justin Sherrill almost 3 years ago

  • Priority changed from Normal to Urgent

#3 Updated by Eric Helms almost 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Eric Helms

#4 Updated by Jorick Astrego almost 3 years ago

I don't know if you have the same issue, but I had this error and solved it by adding the capsule fqdn and ip to /etc/hosts on the main katello server.

After I did this, things worked without this error.

#5 Updated by Simone Caldana almost 3 years ago

I have the same problem (3.2.0-rc4), and the issue is that the capsule installer doesn't wait for the local daemon on port 9090 to become available before subscribing itself to katello. The result is that the katello server queries the capsule... which is not up (yet), hence the connection refused.
If I relaunch the installer it works correctly, because the capsule is already up.
This didn't happen in 3.0 or 3.1, and depending on the relative speed of the hosts may not happen every time, as it's 99% a race condition betwee the capsule startup and the subscription to katello.

#6 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) changed from 162 to 197

#7 Updated by Mario Gamboa almost 3 years ago

I have same issues with the rc4 every time to try add a capsule i just give it up and install 3.1 that looks more stable

#8 Updated by John Mitsch almost 3 years ago

Mario Gamboa wrote:

I have same issues with the rc4 every time to try add a capsule i just give it up and install 3.1 that looks more stable

A work around for this bug is to re-run the capsule installer

#9 Updated by Eric Helms almost 3 years ago

  • Legacy Backlogs Release (now unused) changed from 197 to 208

#10 Updated by John Mitsch over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 208 to 214

#11 Updated by Daniel Kimsey over 2 years ago

I ran into this as well during the 3.2 upgrade of my capsules.

Re-running had no effect, the installer wanted to restart the foreman-proxy service everytime.

My "solution" was to hack in a wait period. Seemed to help.

Changing /usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp:

--- register.pp 2017-01-24 12:49:13.981489759 -0600
+++ register.hack.pp    2017-01-24 12:49:05.494268892 -0600
@@ -2,6 +2,10 @@
 class foreman_proxy::register {

   if $foreman_proxy::register_in_foreman {
+    exec {"wait for proxy to be available":
+       require => Service["foreman-proxy"],
+       command => "/usr/bin/wget --spider --tries 10 --retry-connrefused --no-check-certificate $foreman_proxy::real_registered_proxy_url/pulpnode/status/puppet",
+    }
     foreman_smartproxy { $foreman_proxy::registered_name:
       ensure          => present,
       base_url        => $foreman_proxy::foreman_base_url,

#12 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 214 to 222

#13 Updated by Mario Gamboa over 2 years ago

i just get now same issues when try to upgrade to 3.3 from 3.1

#14 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) deleted (222)

#15 Updated by Eric Helms over 2 years ago

  • Status changed from Assigned to Closed
  • Legacy Backlogs Release (now unused) set to 228
  • Pull request https://github.com/Katello/puppet-service_wait/pull/26 added

Also available in: Atom PDF