Project

General

Profile

Bug #16674

when downloading boot images, a failure does not fail the operation in the UI

Added by Daniel Gagnon about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When setting build mode on a host, the proxy downloads the required files from boot from the internet. If the download fails, the build mode is expected to fail, but it suceeds. The host cannot be provisioned since the files are not available.

D, [2016-09-23T12:13:35.773914 #22221] DEBUG -- : accept: 64.15.64.152:59915
D, [2016-09-23T12:13:35.776761 #22221] DEBUG -- : Rack::Handler::WEBrick is invoked.
D, [2016-09-23T12:13:35.778239 #22221] DEBUG -- : verifying remote client 64.15.64.152 against trusted_hosts ["127.0.0.1", "pxe-prod.clients.netelligent.ca", "64.15.64.152", "68.168.118.38"]
D, [2016-09-23T12:13:35.779017 #22221] DEBUG -- : Starting task: /usr/bin/wget --timeout=10 --tries=3 --no-check-certificate -nv -c "http://debian.mirror.netelligent.ca/debian//dists/wheezy/main/installer-amd64/current/images/netboot/debian-installer/amd64/initrd.gz" -O "/srv/tftp/boot/Debian-7.11-x86_64-initrd.gz" 
I, [2016-09-23T12:13:35.779450 #22221]  INFO -- : 64.15.64.152 - - [23/Sep/2016 12:13:35] "POST /tftp/fetch_boot_file HTTP/1.1" 200 - 0.0015

D, [2016-09-23T12:13:35.785705 #22221] DEBUG -- : close: 64.15.64.152:59915
E, [2016-09-23T12:13:35.794993 #22221] ERROR -- : [24139] http://debian.mirror.netelligent.ca/debian//dists/wheezy/main/installer-amd64/current/images/netboot/debian-installer/amd64/initrd.gz:

E, [2016-09-23T12:13:35.795110 #22221] ERROR -- : [24139] 2016-09-23 12:13:35 ERROR 404: Not Found.
==> /var/log/apache2/foreman-ssl_access_ssl.log <==
68.168.118.38 - - [23/Sep/2016:12:13:34 -0400] "POST /hosts/debian7.clients.netelligent.ca/setBuild?auth_object=debian7.clients.netelligent.ca&permission=build_hosts HTTP/1.1" 302 142 "https://pxe-prod.clients.netelligent.ca/hosts/debian7.clients.netelligent.ca" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 OPR/39.0.2256.71" 
68.168.118.38 - - [23/Sep/2016:12:13:35 -0400] "GET /hosts/debian7.clients.netelligent.ca HTTP/1.1" 200 19100 "https://pxe-prod.clients.netelligent.ca/hosts/debian7.clients.netelligent.ca" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 OPR/39.0.2256.71" 

Related issues

Related to Smart Proxy - Feature #3034: TFTP file download should be synchronous and handle errorsNew

History

#1 Updated by Dmitri Dolguikh about 5 years ago

  • Status changed from New to Duplicate

Thanks for reporting this, but it's a duplicate of #3034

#2 Updated by Dmitri Dolguikh about 5 years ago

  • Related to Feature #3034: TFTP file download should be synchronous and handle errors added

Also available in: Atom PDF