Project

General

Profile

Bug #16709

When a sync plan is active, the synchronization is started automatically after a Red Hat product or custom product is added to the sync plan

Added by Justin Sherrill almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Sync Plans
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1279539
Description of problem:

When a sync plan is active, the synchronization is started automatically after enabling a Red Hat Repository

Version-Release number of selected component (if applicable):
Satellite 6.1.3

How reproducible:
100%

Steps to Reproduce:
1. Create a daily sync plan for Red Hat Enterprise Linux Server
2. Enable a Red Hat repository

Actual results:

The synchronization will start automatically even when it is not the expected time according with the sync plan.

Expected results:

Must follow the sync plan

Additional info:

If a sync plan does not exist, it works as expected.

Associated revisions

Revision aeeb539e (diff)
Added by Justin Sherrill almost 3 years ago

Fixes #16709 - only schedule sync plans in the future

because pulp supports scheduling sync schedules in the past
and treats that as user intent that they wanted to sync in the past
we have to set all schedules in the future.

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6349 added

#2 Updated by Justin Sherrill almost 3 years ago

  • Category set to Sync Plans
  • Target version set to 129
  • Difficulty set to medium

#3 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 162

#4 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF