Project

General

Profile

Bug #16716

Error message should appear in another pop-up window in case vlan-id is invalid

Added by Sachin Ghai over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Image
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I see a new option with discovery image where we can pass vlan-id, and in case of invalid vlan-id, the error message appears on same screen and looks distorted. It remains in the background on next screens as well.

Ideally error should be raised in another pop-up window and on same screen, like we are raising on 'Network Configuration screen while validating IPv4 address.


Related issues

Has duplicate Discovery - Bug #16068: Kernel messages hovering over Discovery interfaceNew2016-08-11

History

#1 Updated by Sachin Ghai over 2 years ago

image version FDI 3.2

#2 Updated by Lukas Zapletal over 2 years ago

  • Status changed from New to Duplicate

Sachin, I believe this is dupe of #16068 can you ack please?

#3 Updated by Lukas Zapletal over 2 years ago

  • Has duplicate Bug #16068: Kernel messages hovering over Discovery interface added

#4 Updated by Sachin Ghai over 2 years ago

I think this issue is slightly different. Here we provided invalid vlan-id and console message says: "eth<vlan_id> link is not ready", so if there is any validation around "vlan id" then the message should appear in another pop-up window.

#5 Updated by Lukas Zapletal over 2 years ago

I see, but the end result is the same - error appears over our window.

We can change this ticket to something like "validate VLAN field" but what do you expect I should validate? A number? Will that help?

Also available in: Atom PDF