Project

General

Profile

Bug #1673

Foreman doesn't work with ruby_parser 2.0.6

Added by Ivan Necas about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Trying to run Foreman when ruby_parser 2.0.6 is installed fails with the following error:

/usr/share/foreman/app/models/environment.rb:1: superclass mismatch for class Environment (TypeError)

This is caused by this versions ruby_parser defining Environment constant itself. With version 2.3.1 this is not the case.

It means Foreman is dependent on this or higher version being installed and therefore it should be added to Gemfile (patch attached), and also into RPMS and DEBS explicitly.

fix_ruby_parser_dependency.patch fix_ruby_parser_dependency.patch 342 Bytes Ivan Necas, 06/07/2012 11:48 AM

Associated revisions

Revision 80419840 (diff)
Added by Ivan Necas about 7 years ago

fixes #1673 - Foreman doesn't work with ruby_parser 2.0.6

Explicitly stating the version of ruby_parser that works with Foreman.
Otherwise you might get:

superclass mismatch for class Environment (TypeError)

History

#1 Updated by Ohad Levy about 7 years ago

Do you want to send a git formatted patch / pull request instead? so we could blame you in the future? :)

#3 Updated by Ivan Necas about 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Ohad Levy about 7 years ago

  • Target version set to 1.0

Also available in: Atom PDF