Project

General

Profile

Bug #16751

-capsule-puppet false doesnt work

Added by Sean O'Keeffe about 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Installing a capsule and append the following to the install line:
--foreman-proxy-puppetca false\
-capsule-puppet false

This fails.

Version-Release number of selected component (if applicable):
6.2.2

How reproducible:
100%

Steps to Reproduce:
1. install capsule with --capsule-puppet false and --foreman-proxy-puppetca false
2.
3.

Actual results:
Proxy capsule.sokeeffe.com cannot be registered (422 Unprocessable Entity): Unable to communicate with the Capsule: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([Errno::EHOSTUNREACH]: No route to host - connect(2) for "capsule.sokeeffe.com" port 9090) for Capsule https://capsule.sokeeffe.com:9090/features Please check the Capsule is configured and running on the host.
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[capsule.sokeeffe.com]/ensure: change from absent to present failed: Proxy capsule.sokeeffe.com cannot be registered (422 Unprocessable Entity): Unable to communicate with the Capsule: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([Errno::EHOSTUNREACH]: No route to host - connect(2) for "capsule.sokeeffe.com" port 9090) for Capsule https://capsule.sokeeffe.com:9090/features Please check the Capsule is configured and running on the host.
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[capsule.sokeeffe.com]: Failed to call refresh: Proxy capsule.sokeeffe.com cannot be registered (ApipieBindings::MissingArgumentsError: id): N/A
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[capsule.sokeeffe.com]: Proxy capsule.sokeeffe.com cannot be registered (ApipieBindings::MissingArgumentsError: id): N/A
Could not start Service[httpd]: Execution of '/usr/share/katello-installer-base/modules/service_wait/bin/service-wait start httpd' returned 1: Redirecting to /bin/systemctl start httpd.service
/Stage[main]/Apache::Service/Service[httpd]/ensure: change from stopped to running failed: Could not start Service[httpd]: Execution of '/usr/share/katello-installer-base/modules/service_wait/bin/service-wait start httpd' returned 1: Redirecting to /bin/systemctl start httpd.service
Installing Done [100%] [...............................................................................................................................]
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/foreman-installer/capsule.log
[root@capsule ~]#

Expected results:
this to work

Additional info:

History

#1 Updated by Sean O'Keeffe about 4 years ago

Turns out this has already been fixed with https://github.com/Katello/puppet-capsule/pull/92.

#2 Updated by Justin Sherrill about 4 years ago

  • Status changed from New to Closed
  • Legacy Backlogs Release (now unused) set to 188
  • Pull request https://github.com/Katello/puppet-capsule/pull/92 added

Also available in: Atom PDF