Project

General

Profile

Bug #16777

Content View Filter Rule version dropdown menu should place the input textbox to the right of the version dropdown

Added by Andrew Kofink over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1381250
Description of problem:
The dropdown menu for content view filter rule version (all versions, equal to, greater than, etc.) should make room for the text box that shows when the user selects any option other than "All Versions" so that the text box is displayed to the right of the dropdown field rather than below it.

Version-Release number of selected component (if applicable):
Reproducible in Satellite 6.2
How reproducible:
Always
Steps to Reproduce:
1. Create a content view package filter
2. In the new rule view, select "Greater Than"
Actual results:
The text box is shown below the drop down
Expected results:
The text box(es) should be shown to the right of the drop down
Additional info:
The drop down is a class=col-sm-12 to begin with and changes to a class=col-sm-7 when showing anything but the "all" option. The issue is that the class=col-sm-12 is not toggled off when the class=col-sm-7 is added.

Associated revisions

Revision 66afbd18 (diff)
Added by Andrew Kofink over 4 years ago

Fixes #16777 - Adjust input widths on rule create

ContentViewFilterRule#Create, inside the content view filter show page,
now displays appropriate widths for all date inputs (greater, less than,
range) such that all inputs display properly on one row without
wrapping.

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Andrew Kofink
  • Pull request https://github.com/Katello/katello/pull/6371 added

#2 Updated by Brad Buckingham over 4 years ago

  • Subject changed from Content View Filter Rule version dropdown menu should place the input textbox to the right of the version dropdown to Content View Filter Rule version dropdown menu should place the input textbox to the right of the version dropdown
  • Target version set to 129

#3 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 188
  • Difficulty set to easy

#4 Updated by Andrew Kofink over 4 years ago

  • Target version changed from 129 to 147

#5 Updated by Andrew Kofink over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF