Project

General

Profile

Bug #16820

Upgrading Katello 3.1 to 3.2 Error with /usr/bin/grub2-mkimage

Added by Rob Doeser over 4 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Upgrade Step: Running installer...
 /usr/bin/grub2-mkimage -O x86_64-efi -d /usr/lib/grub/x86_64-efi -o /var/lib/tftpboot/grub2/grubx64.efi -p '' all_video boot btrfs cat chain configfile echo efifwsetup efinet ext2 fat font gfxmenu gfxterm gzio halt hfsplus iso9660 jpeg loadenv loopback lvm mdraid09 mdraid1x minicmd normal part_apple part_msdos part_gpt password_pbkdf2 png reboot search search_fs_uuid search_fs_file search_label serial sleep syslinuxcfg test tftp video xfs linux backtrace usb usbserial_common usbserial_pl2303 usbserial_ftdi usbserial_usbdebug linuxefi returned 1 instead of one of [0]

When running this command manually it says the directory does not exist.
It can be solved manually by creating the directories and run the upgrade again.

mkdir /var/lib/tftboot/grub2
mkdir /var/lib/tftboot/grub

Expected results:
foreman-installer should create the directories for me if they don't exist.

How to reproduce:
If there is no grub2 dir in /var/lib/tftpboot.

https://git.io/vi4yY should have taken care of that


Related issues

Related to Installer - Feature #12635: Options to deploy Grub and PXELinux EFI loaders in TFTP rootClosed2015-11-30
Is duplicate of Katello - Bug #17639: Upgrade fails if /var/lib/tfpboot/grub2 is not pre-createdClosed2016-12-12

History

#1 Updated by Anonymous over 4 years ago

  • Related to Feature #12635: Options to deploy Grub and PXELinux EFI loaders in TFTP root added

#2 Updated by Anonymous over 4 years ago

  • Difficulty deleted (easy)

#3 Updated by Ewoud Kohl van Wijngaarden over 4 years ago

It would help to know which OS you are on.

#4 Updated by Rob Doeser over 4 years ago

Ewoud Kohl van Wijngaarden wrote:

It would help to know which OS you are on.

CentOS 7.2 Fully Patched till 6-10-2016
Kernel 3.10.0-327.36.1.el7.x86_64

#5 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) changed from 162 to 197

#6 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) changed from 197 to 208

#7 Updated by John Mitsch over 4 years ago

  • Legacy Backlogs Release (now unused) changed from 208 to 214

#8 Updated by Anonymous over 4 years ago

  • Has duplicate Bug #17356: Upgrade to 3.2 get the following error added

#9 Updated by Anonymous over 4 years ago

  • Has duplicate deleted (Bug #17356: Upgrade to 3.2 get the following error)

#10 Updated by Anonymous over 4 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) deleted (214)

#11 Updated by Anonymous over 4 years ago

  • Is duplicate of Bug #17639: Upgrade fails if /var/lib/tfpboot/grub2 is not pre-created added

#12 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF