Project

General

Profile

Bug #16849

hammer info doesn't return all values for location

Added by Adam Ruzicka almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Organizations and locations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1233612

Description of problem:
We can create new 'Location' object with, for example, description:
hammer u admin -p changeme location create --name Test01 --description Test01
But there are no way to get information about location description through hammer:
hammer -u admin -p changeme location info --name Test01
--------------------------------------

Id: 228
Name: Test01
Users:

Smart proxies:

Subnets:

Compute resources:

Installation media:

Templates:
Boot disk iPXE - generic host (Bootdisk)
...
Domains:

Environments:

Hostgroups:

Parameters:

Created at: 2015/06/19 09:11:04
Updated at: 2015/06/19 09:11:04
------------------------------------------

Version-Release number of selected component (if applicable):
snap8

How reproducible:
Always

Steps to Reproduce:
1. Create new location through CLI
2. Read information about just created entity

Actual results:
There are no information about location description in 'hammer location info' output

Expected results:
Necessary information can be received through CLI

Additional info:


Related issues

Is duplicate of Hammer CLI - Feature #15502: Add description to location/organization list Closed2016-06-22

History

#1 Updated by Adam Ruzicka almost 5 years ago

  • Category changed from Other commands to Organizations and locations

Description is sent from the server but ignored when hammer generates the output

#2 Updated by Adam Ruzicka almost 5 years ago

  • Status changed from New to Closed

Upstream is not affected by this, closing.

#3 Updated by Adam Ruzicka almost 5 years ago

  • Is duplicate of Feature #15502: Add description to location/organization list added

#4 Updated by Adam Ruzicka almost 5 years ago

  • Status changed from Closed to Duplicate

Also available in: Atom PDF