Project

General

Profile

Bug #16898

Dependency problems with foreman-installer

Added by Ben Howell about 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Debian/Ubuntu
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Attempting to run foreman-installer on Ubuntu Xenial 16.04.1 results in package dependencies with ruby-concurrent.

[ERROR 2016-10-12T16:31:29 verbose]  ruby-dynflow : Depends: ruby-concurrent-ruby-edge (>= 0.2.0) but it is not going to be installed
[ERROR 2016-10-12T16:31:29 verbose]                 Depends: ruby-concurrent-ruby-edge (< 1.0.0) but it is not going to be installed
---
[ERROR 2016-10-12T16:31:28 verbose]  ruby-foreman-remote-execution : Depends: ruby-foreman-tasks (>= 0.8.2) but it is not going to be installed
[ERROR 2016-10-12T16:31:28 verbose]                                  Depends: ruby-foreman-tasks (< 0.9.0) but it is not going to be installed
[ERROR 2016-10-12T16:31:28 verbose]                                  Depends: ruby-foreman-deface but it is not going to be installed

Attempting to install the packages manually I get this error:

root@foreman-dev:~# apt-get install ruby-concurrent-ruby-edge --no-install-recommends
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  ruby-concurrent
The following NEW packages will be installed:
  ruby-concurrent ruby-concurrent-ruby-edge
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/177 kB of archives.
After this operation, 1,042 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 99687 files and directories currently installed.)
Preparing to unpack .../ruby-concurrent_1.0.0-1_all.deb ...
Unpacking ruby-concurrent (1.0.0-1) ...
Selecting previously unselected package ruby-concurrent-ruby-edge.
Preparing to unpack .../ruby-concurrent-ruby-edge_0.2.0-2_all.deb ...
Unpacking ruby-concurrent-ruby-edge (0.2.0-2) ...
dpkg: error processing archive /var/cache/apt/archives/ruby-concurrent-ruby-edge_0.2.0-2_all.deb (--unpack):
 trying to overwrite '/usr/lib/ruby/vendor_ruby/concurrent/channel.rb', which is also in package ruby-concurrent 1.0.0-1
Errors were encountered while processing:
 /var/cache/apt/archives/ruby-concurrent-ruby-edge_0.2.0-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Apparently both ruby-concurrent and ruby-concurrent-ruby-edge are trying to provide the same things and stepping on each other, even though they're dependencies?


Related issues

Related to Packaging - Bug #17064: Foreman installer broken on Ubuntu XenialResolved2016-10-23

Associated revisions

Revision 39b9e861
Added by Dominic Cleal about 4 years ago

fixes #16898 - delete concurrent-ruby-edge for xenial

History

#1 Updated by Anonymous about 4 years ago

  • Assignee set to Anonymous
  • Project changed from Foreman to Packaging
  • Category set to Debian/Ubuntu

#2 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/1383 added

#3 Updated by Dominic Cleal about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 190

New versions of ruby-dynflow with the ruby-concurrent-edge dependency removed should be out in the next patch release, while ruby-concurrent-edge will be deleted in 1.14.0 as it's incompatible with the version in 16.04.

#5 Updated by Anonymous about 4 years ago

  • Related to Bug #17064: Foreman installer broken on Ubuntu Xenial added

#6 Updated by Ben Howell about 4 years ago

I was able to manually install ruby-smart-proxy-remote-execution-ssh successfully after installing this version of dynflow and its dependencies.

Also available in: Atom PDF