Project

General

Profile

Bug #16923

Pulp repositories check before upgrade

Added by Ivan Necas over 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Upgrades
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

We've run into issues with Katello's import_rpms migration, when the Katello
repos were out of sync from the Pulp ones. We should make sure the
katello's and pulp's repositories are not out of sync and offering tooling to fix
it when it happens.

See https://gist.github.com/jlsherrill/323af08409f30b9e90c16f20f7287f68 for
a simple example of how to do it.


Related issues

Is duplicate of Katello - Bug #18405: Update installer upgrade process to include resolving data integrity issues.Closed2017-02-06

History

#1 Updated by Eric Helms over 5 years ago

  • Subject changed from Pulp repositories check before upgrade to Pulp repositories check before upgrade
  • Legacy Backlogs Release (now unused) set to 197

#2 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 197 to 208

#3 Updated by John Mitsch over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 208 to 214

#4 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 214 to 222

#5 Updated by Brad Buckingham almost 5 years ago

  • Is duplicate of Bug #18405: Update installer upgrade process to include resolving data integrity issues. added

#6 Updated by Brad Buckingham almost 5 years ago

  • Status changed from New to Resolved
  • Legacy Backlogs Release (now unused) changed from 222 to 166

Also available in: Atom PDF