Project

General

Profile

Bug #16935

updating a NIC's "Device identifier" if it doesn't already have one fails if the "Device identifier" includes a . or :

Added by Sean O'Keeffe over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Network
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
updating a NIC's "Device identifier" if it doesn't already have one fails if the "Device identifier" includes a . or :

Version-Release number of selected component (if applicable):
nightly

How reproducible:
100%

Steps to Reproduce:
1. Create a new ( dont set Device identifier on the NIC)
2. edit host and try to set Device identifier to eth1:210 for example
3.

Actual results:
Error: Can't add or remove : from identifier

Expected results:
to be able to set it.

Additional info


Related issues

Related to Foreman - Bug #10566: Unique interface identifier requirement prevents host from being edited if duplicate identifier existsClosed2015-05-20
Related to Foreman - Bug #17494: Test fails because of the stray `end` in the test fileClosed2016-11-27
Related to Foreman - Bug #13161: bond0.vlan breaks fact uploadResolved2016-01-12

Associated revisions

Revision 16cbc5c3 (diff)
Added by Sean O'Keeffe over 2 years ago

Fixes #16935 - Allow : & . device ID if there isnt one set

Revision acf0b36c (diff)
Added by Sean O'Keeffe over 2 years ago

Fixes #16935 - Allow : & . device ID if there isnt one set

(cherry picked from commit 16cbc5c31d1bc12b10ebf2d9bb40e5b0e33d9e06)

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3942 added

#2 Updated by Sean O'Keeffe over 2 years ago

I forgot to add downstream bug link: https://bugzilla.redhat.com/show_bug.cgi?id=1384980

#3 Updated by Dominic Cleal over 2 years ago

  • Related to Bug #10566: Unique interface identifier requirement prevents host from being edited if duplicate identifier exists added

#4 Updated by Dominic Cleal over 2 years ago

Linked bug explicitly prevented interfaces from changing their type, by adding an identifier to a physical interface to change it to a virtual interface.

#5 Updated by Marek Hulán over 2 years ago

  • Category changed from Orchestration to Network

#6 Updated by Daniel Lobato Garcia over 2 years ago

  • Bugzilla link set to 1384980

#7 Updated by Marek Hulán over 2 years ago

  • Legacy Backlogs Release (now unused) set to 189

#8 Updated by Sean O'Keeffe over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#9 Updated by Dominic Cleal over 2 years ago

  • Related to Bug #17494: Test fails because of the stray `end` in the test file added

#10 Updated by Marek Hulán over 2 years ago

Did you also find out why the tests in this PR succeeded?

#11 Updated by Marek Hulán over 2 years ago

  • Related to Bug #13161: bond0.vlan breaks fact upload added

Also available in: Atom PDF