Project

General

Profile

Bug #16943

installer removes any qpid tuning for large deployments

Added by Stephen Benjamin over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1273168
Description of problem:

Our own documentation tells customer to tune the qpid component
of Satellite 6 to support larger deployments. See [1]

Running either katello-installer or capsule-installer as part
of a normal upgrade will remove any tuning which has been done
for larger deployments, and will revert /etc/qpid/qpidd.conf
to a simple config for a small deployment

Version-Release number of selected component (if applicable):

6.1.3

How reproducible:

100%

Steps to Reproduce:
1. Edit /etc/qpid/qpidd.conf, set `max-connections=2500`
2. Run katello-installer or capsule-installer --upgrade
3.

Actual results:

View /etc/qpid/qpidd.conf, note that max-connections setting is gone.

Expected results:

qpid tuning which is done according to our documentation to support
a larger deployment should be maintained.

Additional info:

[1] - https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Prerequisites.html#sect-Red_Hat_Satellite-Installation_Guide-Prerequisites-Large_deployments

History

#1 Updated by Stephen Benjamin over 5 years ago

  • Subject changed from installer removes any qpid tuning for large deployments to installer removes any qpid tuning for large deployments
  • Status changed from New to Closed

Not an issue anymore since clients connect to dispatch router not qpid.

#2 Updated by Eric Helms over 5 years ago

  • Status changed from Closed to Rejected
  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF