Project

General

Profile

Bug #1700

Large audit log takes a long time to pull up. (25 secs+)

Added by Brian Gupta about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Audit Log
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Need to set to debug, and see which query is taking a long time.

Associated revisions

Revision de3fb0d7 (diff)
Added by Amos Benari about 7 years ago

fixes #1700 audit page performance improved

  • Added auditabale name and associated name columns.
  • Added username to audit table

Revision e2217aa6 (diff)
Added by Ohad Levy about 7 years ago

minor fixing to audits search link, closes #1700

Revision a3b62913 (diff)
Added by Ohad Levy about 7 years ago

ensure that migration script is a bit more rubost for audit uses, refs #1700

(sadly the audited gem alias the .user method, and sometime returns
strings and other times return a user object)

History

#1 Updated by Brian Gupta about 7 years ago

  • Assignee set to Ohad Levy

#2 Updated by Ohad Levy about 7 years ago

  • Assignee changed from Ohad Levy to Amos Benari

#3 Updated by Amos Benari about 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Brian Gupta about 7 years ago

Performance is a lot better, but I may have discovered a regression.

I'm not 100% sure if it's related, but now searching the audit history by user seems to be broken, and it was (Largely) working a couple days ago.

Mmmm. Testing further indicated that for example if my username is bgupta and my display name is "Brian Gupta", if I click on a name in the audit list, it searchs for the display name, which doesn't work, but if I manually type in my login name (bgupta) into the search it works. Searching for the Admin user audit still seems broken.

#5 Updated by Ohad Levy about 7 years ago

  • Status changed from Closed to Assigned
  • Target version set to 1.0

#6 Updated by Ohad Levy about 7 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF