Bug #17083

TFTP orchestration is silently skipped when there is an AR error

Added by Lukas Zapletal over 1 year ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assignee:Lukas Zapletal
Category:TFTP
Target version:1.4.3
Difficulty: Team Backlog:
Triaged: Fixed in Releases:
Bugzilla link:1388104 Found in Releases:
Pull request:https://github.com/theforeman/foreman/pull/3969

Description

If there is an ActiveRecord error during unattended/built orchestration (queue_tftp), the method silently does not enqueue TFTP orchestration. We should print the error in logs, otherwise it is impossible to investigate the root cause.

Symptoms are even more difficult to spot because due to bug #17082 no error is reported when unattended "built" REST API call fails, so the TFTP orchestration is silently ignored and hosts stays in provisioning loop.


Related issues

Related to Foreman - Bug #17082: New host form network tab validations are broken Duplicate 10/25/2016

Associated revisions

Revision c6294926
Added by Lukas Zapletal 5 months ago

Fixes #17083 - log skipped orchestration steps

History

#1 Updated by Lukas Zapletal over 1 year ago

  • Related to Bug #17082: New host form network tab validations are broken added

#2 Updated by Lukas Zapletal over 1 year ago

  • Bugzilla link set to 1388104

#3 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3969 added

#4 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version set to 1.5.2

#5 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version changed from 1.5.2 to 1.4.3

#6 Updated by Lukas Zapletal 5 months ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF