Project

General

Profile

Bug #17209

hammer host create doesn't inherit content_facet_attributes from hostgroups

Added by Simone Caldana over 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Hammer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

hammer host create doesn't expose parameters to set content_facet_attributes which are needed to provision hosts using synced content.
the same attributes can be set thru the API.

verified in 3.2.0-rc3


Related issues

Is duplicate of Katello - Bug #17389: Host created via hammer does not show the CV & Lifecycle Environment inherited from hostgroupResolved2016-11-17

History

#1 Updated by Simone Caldana over 5 years ago

Specifying --kickstart-repository-id --content-view-id AND --lifecycle-environment-id in host create works, despite specifying a hostgroup where these three attributes are already set.

The bug is therefore "hammer host create doesn't inherit content_facet_attributes from hostgroups"

Thanks to IRC/jsherrill for the help

#2 Updated by Justin Sherrill over 5 years ago

  • Subject changed from Hammer extension does not provide access for setting content_facet_attributes to hammer host create doesn't inherit content_facet_attributes from hostgroups

#3 Updated by Justin Sherrill over 5 years ago

  • Assignee set to Justin Sherrill

#4 Updated by Eric Helms over 5 years ago

  • Status changed from New to Resolved
  • Legacy Backlogs Release (now unused) set to 166

#5 Updated by Andrew Kofink over 5 years ago

  • Is duplicate of Bug #17389: Host created via hammer does not show the CV & Lifecycle Environment inherited from hostgroup added

Also available in: Atom PDF