Project

General

Profile

Feature #17240

smart-proxy-openscap-send with additional features - alert if file corrupt

Added by Ondřej Pražák almost 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1332702
Description of problem: After normal cron execution, the script smart-proxy-openscap-send in the Satellite server leave some files in the spool directory (the ones that coannot be uploaded), so the workaround should be rerun the command or check what file is corrupt.

Steps to Reproduce:
1. Configure openscap
2. Configure client, and force a new generation / send report
3. Corrupt report file in /var/spool/foreman-proxy/openscap/arf/* with 'fallocate -l 2 -p reportfile'
4. execute the script smart-proxy-openscap-send
Actual results:
Some files in the directory /var/spool/foreman-proxy/openscap/arf/* will not be processed and the admin will not be notified about it.
Expected results:
Any kind of notification that not all reports from spool were uploaded.

Related issues

Related to OpenSCAP - Bug #19196: smart_proxy_openscap has multi-line statement that's incompatible with 1.8.7Closed2017-04-06

Associated revisions

Revision f3ade21b (diff)
Added by Ondřej Pražák over 1 year ago

Fixes #17240 - Process all files in spool

Revision 1e596e42 (diff)
Added by Ondřej Pražák over 1 year ago

Fixes #17240 - Add spool failure warning

Revision ae90e570
Added by Marek Hulán over 1 year ago

Merge pull request #235 from xprazak2/spool-warn

Fixes #17240 - Add spool failure warning

Revision 14e36acc
Added by Marek Hulán over 1 year ago

Merge pull request #44 from xprazak2/corrupt-arf-check

Fixes #17240 - Process all files in spool

History

#1 Updated by Ondřej Pražák almost 2 years ago

  • Subject changed from smart-proxy-openscap-send with additional features - alert if file corrupt to smart-proxy-openscap-send with additional features - alert if file corrupt
  • Priority changed from High to Normal
  • Target version set to 115

#2 Updated by Marek Hulán over 1 year ago

Is this still reproducible with the latest version? Should we report this during the ARF is parsed on the proxy and uploaded to Foreman? If the problem is only with cron job, we should probably improve the output of the task and set MAILTO.

#3 Updated by Ondřej Pražák over 1 year ago

  • Assignee set to Ondřej Pražák

#4 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/smart_proxy_openscap/pull/44 added

#5 Updated by The Foreman Bot over 1 year ago

  • Pull request https://github.com/theforeman/foreman_openscap/pull/235 added

#6 Updated by Marek Hulán over 1 year ago

  • Target version changed from 115 to 1.11.4
  • Legacy Backlogs Release (now unused) set to 200

#7 Updated by Ondřej Pražák over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Marek Hulán over 1 year ago

will be released with smart_proxy_openscap 0.6.2

#9 Updated by Marek Hulán over 1 year ago

  • Related to Bug #19196: smart_proxy_openscap has multi-line statement that's incompatible with 1.8.7 added

Also available in: Atom PDF