Project

General

Profile

Bug #17315

While scheduling remote command on a client system fails with error "TypeError no implicit conversion of Net::SSH::Connection::Channel into String"

Added by Ivan Necas over 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1389262
Description of problem:

While scheduling remote command on a client system fails with error "TypeError no implicit conversion of Net::SSH::Connection::Channel into String"

Version-Release number of selected component (if applicable):
Satellite v 6.2

How reproducible:
Always

Steps to Reproduce:
1. Setup a client with remote execution configured against satellite
2. On client system add echo "hello" to .bashrc file
3. Schedule "df -h" remote command to the client system.

Actual results:

Output:
Error initializing command #<Proxy::RemoteExecution::Ssh::Dispatcher::Command:0x000000033eb680>
TypeError no implicit conversion of Net::SSH::Connection::Channel into String
Exit status: EXCEPTION
Errors:
Script execution failed

Expected results:
Remote command execution should not fail because of the echo statements in .bashrc file.

Additional info:

If we run a remote command using ssh command on a system which has echo statement in .bashrc, it works successfully

Associated revisions

Revision c96c9c5f (diff)
Added by adamruzicka over 5 years ago

Fixes #17315 - Handle output coming from .bashrc

History

#1 Updated by Ivan Necas over 5 years ago

  • Subject changed from While scheduling remote command on a client system fails with error "TypeError no implicit conversion of Net::SSH::Connection::Channel into String" to While scheduling remote command on a client system fails with error "TypeError no implicit conversion of Net::SSH::Connection::Channel into String"
  • Target version set to 1.15.3

#2 Updated by Adam Ruzicka over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Adam Ruzicka

#3 Updated by The Foreman Bot over 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/216 added

#4 Updated by The Foreman Bot over 5 years ago

  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/218 added

#5 Updated by Ivan Necas over 5 years ago

  • Status changed from Ready For Testing to Closed
  • Target version changed from 1.15.3 to 1.11.1

#6 Updated by Ivan Necas over 5 years ago

  • Pull request deleted (https://github.com/theforeman/foreman_remote_execution/pull/216)

Also available in: Atom PDF