Project

General

Profile

Bug #17370

Use copy instead of move in puppet upgrade hook

Added by Stephen Benjamin over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Here:
https://github.com/Katello/katello-installer/blob/master/hooks/pre/31-upgrade-puppet.rb#L21-L22

A user is reporting errors:
--upgrade-puppet copy_data fails on "mv: inter-device move failed: ‘/var/lib/puppet/ssl’ to ‘/etc/puppetlabs/puppet/ssl’; unable to remove target: Directory not empty"


Related issues

Is duplicate of Katello - Bug #18548: Puppet upgrade from 3 to 4: foreman-installer --upgrade-puppet fails on cp of ssl filesClosed2017-02-17

History

#1 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 208

#2 Updated by John Mitsch over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 208 to 214

#3 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 214 to 222

#4 Updated by Eric Helms about 5 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 222 to 166

#5 Updated by Eric Helms about 5 years ago

  • Is duplicate of Bug #18548: Puppet upgrade from 3 to 4: foreman-installer --upgrade-puppet fails on cp of ssl files added

Also available in: Atom PDF