Project

General

Profile

Bug #1738

Puppet Runtime charts look very messed up

Added by Andreas Ntaflos about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Sorry for the not exactly technical summary, but I don't know how else to describe the problem. The Puppet Runtime charts in our Foreman 1.0RC3 installation look very weird after a few days/weeks of incoming reports. Please see these screenshots for illustration:

https://daff.ptmx.org/misc/puppet-runtime-chart.png
https://daff.ptmx.org/misc/puppet-runtime-chart2.png

I can provide more screenshots if needed. Any other info I can provide?

json.log json.log 37.5 KB Romain Vrignaud, 07/20/2012 03:33 AM

Associated revisions

Revision 84d8bcb2 (diff)
Added by Amos Benari about 7 years ago

fixes #1738 Puppet Runtime charts look very messed up.

History

#1 Updated by Ohad Levy about 7 years ago

any chance your clock was not synced correctly?

#2 Updated by Andreas Ntaflos about 7 years ago

Sorry, no. Our clocks are all in sync and monitored by Nagios. It seems the charts start getting messed up only after a few days (two or three) of operation. Here is a screenshot of a host I provisioned this Monday (2012-07-16): https://daff.ptmx.org/misc/foreman3.png

#3 Updated by Romain Vrignaud about 7 years ago

I confirm that I have exactly the same behaviour.
I have also NTP on production.

#4 Updated by Romain Vrignaud about 7 years ago

See JSON attached for example

#5 Updated by Ohad Levy about 7 years ago

  • Assignee set to Amos Benari

#6 Updated by Ohad Levy about 7 years ago

  • Target version set to 1.0

#7 Updated by Amos Benari about 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF