Project

General

Profile

Feature #17398

Fix counts while upgrading Satellite

Added by Stephen Benjamin over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1395797
Description of problem:
It seems that in older version of Satellite, a situation could create a negative count , and this negative counts still persist after upgrading. It can be fix manually by running this:
  1. foreman-rake fix_cached_counters

As a RFE, this actions could be done when upgrading, or in a cron managed by Satellite.

Steps to Reproduce:
1.Modify the count from the database via foreman db, example:
update operatingsystems SET hosts_count = hosts_count -1 WHERE id = '2';

2. Validation the wrong count though the WebUI
Hosts > Operating Systems
Under "Hosts" column, the negative "-1" should be seen
3. Run this command
  1. foreman-rake fix_cached_counters

4. Count in the database and webui will now display to good number.

Expected results:
Have an automated process that fix the counters via cron or uprade process.

History

#1 Updated by Stephen Benjamin over 5 years ago

  • Subject changed from Fix counts while upgrading Satellite to Fix counts while upgrading Satellite
  • Status changed from New to Rejected

Not needed upstream since cache counters are gone.

#2 Updated by Stephen Benjamin over 5 years ago

  • Bugzilla link deleted (1395797)

#3 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF