Project

General

Profile

Actions

Feature #1740

closed

VNC password should be optional on hypervisors

Added by Romain Vrignaud about 12 years ago. Updated almost 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

As http://theforeman.org/issues/1739 is quite annoying for us,
the VNC password for direct connection in hypervisors should be optional.


Related issues 1 (0 open1 closed)

Related to Foreman - Feature #1711: Need an option to choose whether a Libvirt-based VM should have a VNC password set or notClosedGreg Sutcliffe06/26/2012Actions
Actions #1

Updated by Romain Vrignaud about 12 years ago

  • Tracker changed from Bug to Feature
Actions #2

Updated by Joshua Hoblitt over 11 years ago

It would also be very convenient for theforeman to show the password it generated/set somewhere in on the host display. With libvirt, you have to dump the VMs xml config to fish out the vnc passwords that's been set.

Actions #3

Updated by Ryan Davies about 11 years ago

Joshua Hoblitt wrote:

It would also be very convenient for theforeman to show the password it generated/set somewhere in on the host display. With libvirt, you have to dump the VMs xml config to fish out the vnc passwords that's been set.

This would be a fantastic feature

Actions #4

Updated by Benjamin Papillon about 11 years ago

As a workaround I'm viewing the html source where the password is

Actions #5

Updated by Dominic Cleal almost 11 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate

Closing as a duplicate of #1711. This feature has been implemented in https://github.com/theforeman/foreman/pull/753 for Foreman 1.3.

Actions

Also available in: Atom PDF