Project

General

Profile

Bug #17415

Capsule upgrade fails to start httpd due to duplicated WSGI daemon definition

Added by Stephen Benjamin over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Urgent
Category:
Upgrades
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1368085
Description of problem:
On a 6.2.0 Capsule (installed from scratch, never upgraded from 6.1.x), attempting to upgrade to 6.2.1 fails when httpd fails to start due to duplicated WSGI daemon definition.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Install a 6.2.0 Capsule from scratch
2. Run "satellite-installer --scenario capsule --upgrade"

Actual results:
Upgrade Step: start_httpd...
Redirecting to /bin/systemctl start httpd.service
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.

Some services failed to start: httpd

Upgrade step start_httpd failed. Check logs for more information.

  1. systemctl status httpd.service
    httpd.service - The Apache HTTP Server
    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Active: failed (Result: exit-code) since Thu 2016-08-18 06:30:12 EDT; 7min ago
    Docs: man:httpd(8)
    man:apachectl(8)
    Process: 21674 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
    Process: 21672 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
    Main PID: 21672 (code=exited, status=1/FAILURE)

Aug 18 06:30:12 sat62cap.usersys.redhat.com systemd1: Starting The Apache HTTP Server...
Aug 18 06:30:12 sat62cap.usersys.redhat.com httpd21672: AH00526: Syntax error on line 28 of /etc/httpd/conf.d/pulp.conf:
Aug 18 06:30:12 sat62cap.usersys.redhat.com httpd21672: Name duplicates previous WSGI daemon definition.
Aug 18 06:30:12 sat62cap.usersys.redhat.com systemd1: httpd.service: main process exited, code=exited, status=1/FAILURE
Aug 18 06:30:12 sat62cap.usersys.redhat.com kill21674: kill: cannot find process ""
Aug 18 06:30:12 sat62cap.usersys.redhat.com systemd1: httpd.service: control process exited, code=exited status=1
Aug 18 06:30:12 sat62cap.usersys.redhat.com systemd1: Failed to start The Apache HTTP Server.
Aug 18 06:30:12 sat62cap.usersys.redhat.com systemd1: Unit httpd.service entered failed state.
Aug 18 06:30:12 sat62cap.usersys.redhat.com systemd1: httpd.service failed.

Expected results:
Upgrade to 6.2.1. succeeds.

Additional info:


Related issues

Has duplicate Katello - Bug #17616: Katello Capsule 3.2 new installation failedDuplicate2016-12-09

Associated revisions

Revision ad98cc5f (diff)
Added by Stephen Benjamin over 5 years ago

fixes #17415 - remove unmanaged httpd conf files (#436)

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Stephen Benjamin
  • Pull request https://github.com/Katello/katello-installer/pull/436 added

#2 Updated by Eric Helms over 5 years ago

  • Subject changed from Capsule upgrade from 6.2.0 to 6.2.1 fails to start httpd due to duplicated WSGI daemon definition to Capsule upgrade fails to start httpd due to duplicated WSGI daemon definition
  • Legacy Backlogs Release (now unused) set to 188

#3 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 188 to 197

#4 Updated by Anonymous over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by The Foreman Bot over 5 years ago

  • Pull request https://github.com/Katello/katello-installer/pull/450 added

#6 Updated by Justin Sherrill over 5 years ago

  • Has duplicate Bug #17616: Katello Capsule 3.2 new installation failed added

Also available in: Atom PDF