Project

General

Profile

Feature #17418

Allow Pulp to force resync a repository

Added by Brad Buckingham over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1223023

Description of problem:

We've synced varios Red Hat repositories. Some repo sync ran into error and had to be resumed. After that the nightly sync status was "Sync complete". While debugging a provisioning problem we've seen that there have been 183 packages with size of 0 bytes. Even if the repo sync failed we might should compare the md5sum of packages to ensure that they are re-synced again during the next repo sync.

Version-Release number of selected component (if applicable):

Currently 6.1 but the same outcome we've seen already with 6.0 even not sure if it has been based on the same root cause.

How reproducible:

Don't know exactly what has been the root cause of this issue, maybe the repo sync went to stopped with failures.

Actual results:

Broken Packages (size 0 bytes) will not automatically re-synched again.

Expected results:

Check if the package in pulp is really the package which won't be synched again (md5sum) to ensure that it is re-synched if sync failed and the package is not there or unusable.

History

#1 Updated by Eric Helms over 5 years ago

  • Subject changed from Allow Pulp to force resync a repository to Allow Pulp to force resync a repository
  • Priority changed from High to Normal
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Eric Helms over 5 years ago

Sounds like this will require Pulp 2.10

#3 Updated by Brad Buckingham about 5 years ago

  • Assignee deleted (Mike McCune)
  • Target version set to 169

#4 Updated by Justin Sherrill about 5 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) changed from 114 to 166
  • Bugzilla link deleted (1223023)

Closing this as it is being covered by http://projects.theforeman.org/issues/18558

Also available in: Atom PDF