Project

General

Profile

Bug #17505

attempting to assign hypervisor/guest subscriptions yields "too many subscriptions match"

Added by Thomas McKay almost 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
content-hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

To reproduce:

Name,Count,Organization,Environment,Content View,Host Collections,Virtual,Host,OS,Arch,Sockets,RAM,Cores,SLA,Products,Subscriptions
testhypervisor,1,Test Corporation,Library,Default Organization View,,No,,RHEL 7Server,x86_64,4,4 GB,1,,,"" 
testguest%d,2,Test Corporation,Library,Default Organization View,,Yes,testhypervisor,RHEL 7Server,x86_64,1,4GB,1,,"69|Red Hat Enterprise Linux Server","""1|RH00002|Red Hat Enterprise Linux for Virtual Datacenters, Standard|10999110|5700573""" 

Import above and note that the guest subscriptions will fail since after the first one assigned there will be two matching entries, one for the original subscription and one for the newly created guest subscription. The logic should be such that the correct matching subscription from the group should match. (Perhaps the --itemized-subscriptions logic didn't get implemented in the non-itemized mode?)


Related issues

Related to Hammer CLI CSV - Bug #17052: hammer csv can't import activation keys with multiple guest vdc subscriptionsClosed2016-10-20

Associated revisions

Revision afc8539f (diff)
Added by Thomas McKay almost 5 years ago

fixes #17505, #17052 - refine search for subs in act-keys and content-hosts

Revision fde5bf60
Added by Thomas McKay almost 5 years ago

Merge pull request #142 from thomasmckay/1400101-subs

fixes #17505, #17052 - refine search for subs in act-keys and content-hosts

History

#1 Updated by Thomas McKay almost 5 years ago

  • Related to Bug #17052: hammer csv can't import activation keys with multiple guest vdc subscriptions added

#2 Updated by The Foreman Bot almost 5 years ago

  • Pull request https://github.com/Katello/hammer-cli-csv/pull/142 added

#3 Updated by Thomas McKay almost 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Thomas McKay almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 199

#5 Updated by Thomas McKay almost 5 years ago

  • Bugzilla link set to 1400101

Also available in: Atom PDF