Project

General

Profile

Bug #17524

Repository synchronization tries to create all the missing repositories on a remote capsule

Added by Brad Buckingham over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1398438

Description of problem:

If library is synchronized into a capsule, the repository
synchornization also tries to get the content into this capsule.
However, as part of this effort, it checks for all repositories that
were not synchronized into a capsule, and tries to create them there.
This can have a big impact on performance, if there are a lot of
repositories in library, and a new capsule is added to the system to
be synchronized with the library.

How reproducible:
When library is synchonized to capsules

Steps to Reproduce:
1. have a large number of repositories in library
2. add new capsule to the system and add library as an environment to be synchronized
3. synchronize the repository

Actual results:
The synchronization of repository takes much longer, than it should,
the sync task in dynflow sits in "Actions::Katello::Repository::Sync" action,
a lot of trafic between sat and capsule due to checking for status.

Expected results: The sync task is not much slower than without a
capsule present. Only the specific repo is being created when missing on the capsule.

Associated revisions

Revision 8fbcd7f1 (diff)
Added by Brad Buckingham over 5 years ago

fixes #17524 - capsule - update repo creation during repo sync

Currently, when a user syncs a repository (in library) that will
be synced to a capsule, the logic will create all missing
repositories on the capsule. This means that syncing one
repository on a brand new capsule could result in tens or
hundreds of repositories being created.

This commit changes the behavior such that only the repository
being synced will be created. That said, if a user performs
a full sync of the capsule (e.g. from cli or ui via
Infrastructure -> Capsule (or Smart Proxies)), all repositories
will be created.

History

#1 Updated by Brad Buckingham over 5 years ago

  • Subject changed from Repository synchronization tries to create all the missing repositories on a remote capsule to Repository synchronization tries to create all the missing repositories on a remote capsule
  • Target version set to 147
  • Legacy Backlogs Release (now unused) set to 197

#2 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Brad Buckingham
  • Pull request https://github.com/Katello/katello/pull/6475 added

#3 Updated by Brad Buckingham over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF