Project

General

Profile

Bug #17616

Katello Capsule 3.2 new installation failed

Added by Denis Müller over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

yum -y localinstall http://fedorapeople.org/groups/katello/releases/yum/3.2/katello/el7/x86_64/katello-repos-latest.rpm
yum -y localinstall http://yum.theforeman.org/releases/1.13/el7/x86_64/foreman-release.rpm
yum -y localinstall https://yum.puppetlabs.com/puppetlabs-release-pc1-el-7.noarch.rpm
yum -y localinstall http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum -y install foreman-release-scl

foreman-installer --scenario capsule

/usr/share/katello-installer-base/hooks/post/11-create_sslconf.rb:6:in `initialize': No such file or directory - /etc/httpd/conf.d/ssl.conf (Errno::ENOENT)
from /usr/share/katello-installer-base/hooks/post/11-create_sslconf.rb:6:in `open'
from /usr/share/katello-installer-base/hooks/post/11-create_sslconf.rb:6:in `block (4 levels) in load'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hooking.rb:34:in `instance_eval'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hooking.rb:34:in `block (4 levels) in load'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hook_context.rb:13:in `instance_exec'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hook_context.rb:13:in `execute'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hooking.rb:51:in `block in execute'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hooking.rb:49:in `each'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/hooking.rb:49:in `execute'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/kafo_configure.rb:454:in `block in run_installation'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/exit_handler.rb:27:in `call'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/exit_handler.rb:27:in `exit'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/kafo_configure.rb:160:in `exit'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/kafo_configure.rb:453:in `run_installation'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/kafo_configure.rb:147:in `execute'
from /usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
from /usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:133:in `run'
from /usr/share/gems/gems/kafo-0.9.8/lib/kafo/kafo_configure.rb:154:in `run'
from /usr/sbin/foreman-installer:8:in `<main>'

[root@capsule ~]# rpm -qa | grep -i katello

foreman-installer-katello-3.2.1-1.el7.noarch
katello-ca-consumer-theforeman.nodes.rto.de-1.0-3.noarch
katello-repos-3.2.0-4.el7.noarch
katello-selinux-3.0.1-1.el7.noarch
katello-agent-2.6.0-2.el7.noarch
katello-service-3.2.0-4.el7.noarch
katello-certs-tools-2.4.0-1.el7.noarch
katello-installer-base-3.2.1-1.el7.noarch
katello-capsule-3.2.0-4.el7.noarch

For more info theck capsule.log

capsule.log capsule.log 106 KB Denis Müller, 12/09/2016 05:38 AM

Related issues

Is duplicate of Katello - Bug #17415: Capsule upgrade fails to start httpd due to duplicated WSGI daemon definitionClosed2016-11-21

History

#1 Updated by Justin Sherrill over 5 years ago

  • Category set to Installer
  • Status changed from New to Duplicate
  • Assignee set to Stephen Benjamin
  • Legacy Backlogs Release (now unused) set to 166

This should be fixed by http://projects.theforeman.org/issues/17415 which is in 3.2.1 to be released very soon. Will mark as a duplicate.

#2 Updated by Justin Sherrill over 5 years ago

  • Is duplicate of Bug #17415: Capsule upgrade fails to start httpd due to duplicated WSGI daemon definition added

Also available in: Atom PDF