Bug #17631

Validate realms/puppetrun providers

Added by Daniel Lobato Garcia over 1 year ago. Updated 6 days ago.

Status:Closed
Priority:Normal
Assignee:Daniel Lobato Garcia
Category:Foreman modules
Target version:1.15.0
Difficulty: Team Backlog:
Triaged: Fixed in Releases:
Bugzilla link: Found in Releases:
Pull request:https://github.com/theforeman/puppet-foreman_proxy/pull/314

Description

The puppetrun and realm providers accept any value, which can make the installer setup the proxy wrong


Related issues

Related to Installer - Bug #17595: foreman-installer does not check for correct values in DN... Resolved 12/06/2016
Duplicated by Installer - Bug #17117: Document valid values for puppetrun_provider Duplicate 10/27/2016

Associated revisions

Revision 45b8161d
Added by Daniel Lobato García over 1 year ago

Fixes #17631 - Validate puppetrun and realm providers

This commit adds checks for the puppetrun/realms providers so that they
have to be compliant with a certain regex in order to be accepted as
parameters.

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Daniel Lobato Garcia
  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/314 added

#2 Updated by Daniel Lobato Garcia over 1 year ago

  • Related to Bug #17595: foreman-installer does not check for correct values in DNS/DHCP providers added

#3 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version set to 1.4.3

#4 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal over 1 year ago

  • Legacy Backlogs Release (now unused) set to 209

#6 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version changed from 1.4.3 to 1.15.5

#7 Updated by Dominic Cleal over 1 year ago

  • Duplicated by Bug #17117: Document valid values for puppetrun_provider added

Also available in: Atom PDF