Project

General

Profile

Bug #17658

reinstalling katello-ca-consumer on RHEL7 Content Host does not restart goferd service

Added by Stephen Benjamin over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Category:
Client/Agent
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1331710
Description of problem:
Updating SSL certificates on Satellite/Capsule, katello-ca-consumer-latest package needs to be reinstalled on Content Hosts. Post-install script of the package should automatically restart goferd service to let it reload new certificates. But this works only on RHEL[5-6], since:

rpm2cpio /var/www/html/pub/katello-ca-consumer-latest.noarch.rpm | cpio -iv --to-stdout
..

  1. restart goferd if it is installed and running
    [ -f /etc/init.d/goferd ] && \
    service goferd status >/dev/null && \
    service goferd restart >/dev/null 2&>1

exit 0

  1. vim:sw=2:ts=2:et:
    ./usr/bin/katello-rhsm-consumer
    30 blocks

RHEL7 does not have init scripts :-/

Version-Release number of selected component (if applicable):
Sat6.2 Beta Snap 9.3

How reproducible:
100%

Steps to Reproduce:
on RHEL7:
1. ps aux | grep gofer
2. yum reinstall http://satellite.example.com/pub/katello-ca-consumer-latest.noarch.rpm -y
3. ps aux | grep gofer

Actual results:
In 3., same goferd process with same PID is running

Expected results:
In 3., goferd should be restarted

Additional info:
Same bug is in 6.1 and I think this caused lot of redundant customer concerns "why katello agent isnt connected?" resolved by manual goferd restart..

Since change is trivial and has impact to approx. 1/3 of customers (anybody who updates certs), asking for blocker?

Associated revisions

Revision 5e02f1e7 (diff)
Added by Stephen Benjamin over 4 years ago

fixes #17658 - support restarting goferd on OS's with systemd, too (#115)

History

#1 Updated by Justin Sherrill over 4 years ago

  • Subject changed from Satellite 6.2 Beta: reinstalling katello-ca-consumer on RHEL7 Content Host does not restart goferd service to reinstalling katello-ca-consumer on RHEL7 Content Host does not restart goferd service
  • Assignee set to Stephen Benjamin
  • Pull request https://github.com/Katello/puppet-certs/pull/115 added

#2 Updated by Justin Sherrill over 4 years ago

  • Category set to Client/Agent
  • Legacy Backlogs Release (now unused) set to 188

#3 Updated by Anonymous over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF