Project

General

Profile

Feature #17696

make "Red Hat Repositories" page faster by caching/storing data from CDN

Added by Daniel Lobato Garcia over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1381126
Description of problem:
Enabling-disabling a (Red Hat) repository contains lots of spinning hourglasses and is irritatingly slow. One such slowness comes form the fact katello contacts sequentially and everytime CDN to get some repos info:

(debugs in production.log):
2016-10-03 08:09:19 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/listing
2016-10-03 08:09:21 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.1/listing
2016-10-03 08:09:23 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.2/listing
2016-10-03 08:09:25 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.3/listing
2016-10-03 08:09:27 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.4/listing
2016-10-03 08:09:29 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.5/listing
2016-10-03 08:09:31 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.6/listing
2016-10-03 08:09:33 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.7/listing
2016-10-03 08:09:35 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6.8/listing
2016-10-03 08:09:37 [D] CDN: Requesting path https://cdn.redhat.com:443/content/dist/rhel/server/6/6Server/listing

Please either:
- make the calls parallel (why each one takes 2seconds and is made sequentially?)
- or cache the data locally until manifest is updated (such that the calls dont need to be repeated next time)
- or both

Version-Release number of selected component (if applicable):
Sat6.2.1

How reproducible:
100%

Steps to Reproduce:
1. Try to enable a repository and count the time it takes / how much time is spent in waiting on WebUI

Actual results:
A minute or so waited.

Expected results:
repo enabled within few seconds.

Additional info:

Associated revisions

Revision 2011c57b (diff)
Added by Daniel Lobato Garcia over 4 years ago

Fixes #17696 - Make Candlepin API calls smaller

This change affects the redhat repositories page. Prior to this, the
calls were huge, and they were slowing down the load a lot (because of
parsing of the returned data and writing it to logs)

This takes advantage of 'include' in Candlepin's API to request only the
info we need

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Daniel Lobato Garcia
  • Pull request https://github.com/Katello/katello/pull/6500 added

#2 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Daniel Lobato Garcia over 4 years ago

  • Target version set to 1.15.5

#4 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 188

Also available in: Atom PDF