Project

General

Profile

Refactor #17724

Upgrade jQuery to version 3.x

Added by Tomer Brisker over 3 years ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
JavaScript stack
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

We no longer support IE<10, so there is no benefit in running the 1.x version of jQuery which includes a lot of workarounds for older version of IE.
Although there have been some breaking changes, we can take advantage of the jQuery migrate plugin which will let us know if we hit any and provide core and plugin maintainers time to fix any issues.


Related issues

Has duplicate Foreman - Refactor #21860: Update jquery to version 3Duplicate
Has duplicate Foreman - Bug #28806: Foreman uses old version of JQUERY (v2)Duplicate
Blocked by Foreman - Refactor #16285: Move jquery-ui from bundle to npmRejected2016-08-25
Blocked by Foreman - Refactor #21640: Drop jQuery-uiNew2017-11-13
Blocked by Foreman - Bug #12454: Replace gridster.js with another dashboard libraryNew2015-11-12

History

#1 Updated by Tomer Brisker over 3 years ago

#2 Updated by Tomer Brisker over 2 years ago

#3 Updated by Tomer Brisker 4 months ago

#4 Updated by Tomer Brisker 4 months ago

  • Has duplicate Bug #28806: Foreman uses old version of JQUERY (v2) added

#5 Updated by Tomer Brisker 4 months ago

  • Category set to JavaScript stack

#6 Updated by Tomer Brisker 4 months ago

  • Blocked by Bug #12454: Replace gridster.js with another dashboard library added

Also available in: Atom PDF