Project

General

Profile

Bug #17769

hammer host-collection package install : throw exception (404 Resource Not Found)

Added by Andrew Kofink over 2 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1405434
Description of problem:
hammer host-collection package install : throw exception (404 Resource Not Found)

Version-Release number of selected component (if applicable):
candlepin-0.9.54.14-1.el7.noarch
  • candlepin-selinux-0.9.54.14-1.el7.noarch
  • foreman-1.11.0.61-1.el7sat.noarch
  • foreman-compute-1.11.0.61-1.el7sat.noarch
  • foreman-debug-1.11.0.61-1.el7sat.noarch
  • foreman-discovery-image-3.1.1-18.el7sat.noarch
  • foreman-ec2-1.11.0.61-1.el7sat.noarch
  • foreman-gce-1.11.0.61-1.el7sat.noarch
  • foreman-installer-1.11.0.10-1.el7sat.noarch
  • foreman-installer-katello-3.0.0.65-1.el7sat.noarch
  • foreman-libvirt-1.11.0.61-1.el7sat.noarch
  • foreman-openstack-1.11.0.61-1.el7sat.noarch
  • foreman-ovirt-1.11.0.61-1.el7sat.noarch
  • foreman-postgresql-1.11.0.61-1.el7sat.noarch
  • foreman-proxy-1.11.0.7-1.el7sat.noarch
  • foreman-rackspace-1.11.0.61-1.el7sat.noarch
  • foreman-selinux-1.11.0.2-1.el7sat.noarch
  • foreman-vmware-1.11.0.61-1.el7sat.noarch
  • katello-3.0.0-14.el7sat.noarch
  • katello-certs-tools-2.4.0-1.el7sat.noarch
  • katello-client-bootstrap-1.2.2-1.el7sat.noarch
  • katello-common-3.0.0-14.el7sat.noarch
  • katello-debug-3.0.0-14.el7sat.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-base-3.0.0.65-1.el7sat.noarch
  • katello-selinux-3.0.1.2-1.el7sat.noarch
  • katello-server-ca-1.0-1.noarch
  • katello-service-3.0.0-14.el7sat.noarch
  • openldap-2.4.40-13.el7.x86_64
  • pulp-client-1.0-1.noarch
  • pulp-docker-plugins-2.0.3-1.el7sat.noarch
  • pulp-katello-1.0.1-1.el7sat.noarch
  • pulp-ostree-plugins-1.1.3.1-1.el7sat.noarch
  • pulp-puppet-plugins-2.8.7.1-1.el7sat.noarch
  • pulp-puppet-tools-2.8.7.1-1.el7sat.noarch
  • pulp-rpm-plugins-2.8.7.5-1.el7sat.noarch
  • pulp-selinux-2.8.7.3-1.el7sat.noarch
  • pulp-server-2.8.7.3-1.el7sat.noarch
  • python-ldap-2.4.15-2.el7.x86_64
  • tfm-rubygem-ldap_fluff-0.4.3-1.el7sat.noarch
  • tfm-rubygem-net-ldap-0.13.0-1.el7sat.noarch
How reproducible:
Always
Steps to Reproduce:
1.Setup some hosts and a host-collection subscribed to some products containing some packages
2.
hammer host-collection package install --id="col-id" --organization-id="org-id" --packages="package-name"
3.
Actual results:
[ERROR 2016-12-16 08:58:34 Exception] <NilClass> nil
Could not schedule installation of package(s)
[ERROR 2016-12-16 08:58:34 Exception]
RestClient::ResourceNotFound (404 Resource Not Found):
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!'
/opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.0.16/lib/apipie_bindings/api.rb:308:in `block in rest_client_call_block'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:228:in `call'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:228:in `process_result'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:178:in `block in transmit'
/opt/rh/rh-ruby22/root/usr/share/ruby/net/http.rb:853:in `start'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:172:in `transmit'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute'
/opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/resource.rb:76:in `put'
/opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.0.16/lib/apipie_bindings/api.rb:295:in `call_client'
/opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.0.16/lib/apipie_bindings/api.rb:224:in `http_call'
/opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.0.16/lib/apipie_bindings/api.rb:174:in `call_action'
/opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.0.16/lib/apipie_bindings/api.rb:169:in `call'
/opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.0.16/lib/apipie_bindings/resource.rb:14:in `call'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/lib/hammer_cli/apipie/command.rb:43:in `send_request'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.9/lib/hammer_cli_foreman/commands.rb:190:in `send_request'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/lib/hammer_cli/apipie/command.rb:34:in `execute'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/lib/hammer_cli/abstract.rb:22:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/subcommand/execution.rb:11:in `execute'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/lib/hammer_cli/abstract.rb:22:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/subcommand/execution.rb:11:in `execute'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/lib/hammer_cli/abstract.rb:22:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/subcommand/execution.rb:11:in `execute'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/lib/hammer_cli/abstract.rb:22:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:133:in `run'
/opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.11/bin/hammer:125:in `<top (required)>'
/usr/bin/hammer:23:in `load'
/usr/bin/hammer:23:in `<main>'
Expected results:
package-name installed on all hosts of host-collection
Additional info:
on sat 6.3 compose 8, was not able to arrive to this step to test it (should be affected too)

Related issues

Is duplicate of Katello - Bug #15978: hammer host-collection package/package-group/erratum commands use the old systems_controllerClosed2016-08-04

History

#1 Updated by Justin Sherrill over 2 years ago

  • Subject changed from hammer host-collection package install : throw exception (404 Resource Not Found) to hammer host-collection package install : throw exception (404 Resource Not Found)
  • Category set to Hammer
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Brad Buckingham over 2 years ago

  • Target version set to 157

#3 Updated by Andrew Kofink over 2 years ago

  • Is duplicate of Bug #17768: hammer host-collection erratum install : throw exception (404 Resource Not Found) added

#4 Updated by Andrew Kofink over 2 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 114 to 166

#5 Updated by Andrew Kofink over 2 years ago

  • Is duplicate of deleted (Bug #17768: hammer host-collection erratum install : throw exception (404 Resource Not Found))

#6 Updated by Andrew Kofink over 2 years ago

  • Status changed from Duplicate to New
  • Legacy Backlogs Release (now unused) changed from 166 to 114

#7 Updated by Andrew Kofink over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6331 added

#8 Updated by Andrew Kofink over 2 years ago

  • Assignee set to Andrew Kofink

#9 Updated by Andrew Kofink over 2 years ago

  • Is duplicate of Bug #15978: hammer host-collection package/package-group/erratum commands use the old systems_controller added

#10 Updated by Andrew Kofink over 2 years ago

  • Status changed from Ready For Testing to Resolved

Also available in: Atom PDF