Project

General

Profile

Bug #17778

hammer erratum list command taking too much time to display erratum

Added by Andrew Kofink over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1394365
++ This bug was initially created as a clone of Bug #1393611 ++

Description of problem:
hammer erratum list command taking too much time to display erratum, if there are 10+ repositories synchronized into Satellite
Version-Release number of selected component (if applicable):
Satellite 6.2.3
How reproducible:
100%
Steps to Reproduce:
1. Synchronize 10 + Server RPMs and other repositories of different RHEL releases
2. Execute hammer erratum list which seems to be hung for a very long time and response/result is taking more than an hour to display i.e. time varies based upon the number of repositories it has to query.
Actual results:
With 10+ repositories time took to display the result was around
real    69m32.042s
user 66m39.418s
sys 0m1.193s
Expected results:
Should display the result immediately as REST API of the same does.
Additional info:
If we query the same information through REST API, the results are pretty fast.
--- Additional comment from  on 20161110T01:04:07
Since this issue was entered in Red Hat Bugzilla, the pm_ack has been
set to + automatically for the next planned release

History

#1 Updated by Tomáš Strachota over 5 years ago

  • Subject changed from hammer erratum list command taking too much time to display erratum to hammer erratum list command taking too much time to display erratum

We're tracking the core of the problem here: http://projects.theforeman.org/issues/17740 It affects also other index commands, not only errata.

I'm not sure if the issue was double-cloned intentionally. If not, please close as dupe.

#2 Updated by Marek Hulán over 5 years ago

I think this has been wrongly cloned, it's already covered by #17740 and Tomas is working on it. I think it's dupe and should be closed unless you want to track it for some specific Katello release.

EDIT: hm, Tomas was faster and I should reload page before adding comments

#3 Updated by Andrew Kofink over 5 years ago

  • Status changed from New to Duplicate

#4 Updated by Andrew Kofink over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF