Project

General

Profile

Bug #17787

Keyboard tab doesnt function well with Products or Repository page

Added by Brad Buckingham over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1129401

Description of problem:
Keyboard tab doesn't function well with Products or Repository page

Steps to Reproduce:

Products page:
1. Navigate to Content -> Products
2. Click +New Product
3. Enter Name
4. hit Tab
5. Enter Label
6. hit Tab
7. select GPG key (optional)
8. hit Tab
9. select Sync plan (optional)
10. hit Tab again

Actual results:
The focus moves out of my main Product page

Expected results:
After step 10 above:
11. Focus on +New sync Plan
12. hit Tab
13. Enter Desc (optional)
14. hit Tab
15. Type Enter (Save the page)

Repository page:
1. Navigate to Create Repository page
2. Type Name
3. hit Tab
4. type Label
5. hit Tab
6. Two down arrows to select puppet
7. hit Tab 4 times to get to Save button

Actual results:
The focus moves out of my main Product page

Expected results:
The focus should be on Save button so I can click Enter to Save the page.

Additional info:
Please note that there are two pages mentioned in the bug - Product page and repository page.

Associated revisions

Revision 2b95d5d6 (diff)
Added by Kavita Gaikwad over 4 years ago

Fixes #17787 - Keyboard tab doesnt function well

Previously, keyboard tab doesn't function well with Products
or Activation-key page. For repository page, already resolved.

As no need to explicitly set the tabindex
except on customer's demand because it’s all handled in
the browser, in this commit removed existing tabindex attr
from HTML tags.

History

#1 Updated by Brad Buckingham over 4 years ago

  • Subject changed from Keyboard tab doesnt function well with Products or Repository page to Keyboard tab doesnt function well with Products or Repository page
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Legacy Backlogs Release (now unused) deleted (114)
  • Pull request https://github.com/Katello/katello/pull/6509 added

#3 Updated by Kavita Gaikwad over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 188

Also available in: Atom PDF