Project

General

Profile

Bug #17828

Error when synchronizing foreman-releases repo (PLP0000: Importer indicated a failed response)

Added by Pascal Pascher over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I tried to sync yum repos at https://yum.theforeman.org/releases/ but get an error:

"PLP0000: Importer indicated a failed response"

Looking at /var/log/messages I see a "command document too large" from pulp server:

Dec 22 11:57:38 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata from https://yum.theforeman.org/releases/latest/el7/x86_64/.
Dec 22 11:57:39 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): yum.theforeman.org
Dec 22 11:57:41 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Parsing metadata.
Dec 22 11:57:41 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata from https://yum.theforeman.org/releases/latest/el7/x86_64/.
Dec 22 11:57:41 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): yum.theforeman.org
Dec 22 11:57:42 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Parsing metadata.
Dec 22 11:57:42 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata from https://yum.theforeman.org/releases/latest/el7/x86_64/.
Dec 22 11:57:42 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): yum.theforeman.org
Dec 22 11:57:43 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Parsing metadata.
Dec 22 11:57:43 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata files.
Dec 22 11:57:43 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Resetting dropped connection: yum.theforeman.org
Dec 22 11:57:43 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (2): yum.theforeman.org
Dec 22 11:57:43 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (3): yum.theforeman.org
Dec 22 11:57:45 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Generating metadata databases.
Dec 22 11:57:54 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Determining which units need to be downloaded.
Dec 22 11:57:56 katello01 pulp: py.warnings:WARNING: (2711-65216) /usr/lib/python2.7/site-packages/mongoengine/document.py:324: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
Dec 22 11:57:56 katello01 pulp: py.warnings:WARNING: (2711-65216)   object_id = collection.save(doc, **write_concern)
Dec 22 11:57:56 katello01 pulp: py.warnings:WARNING: (2711-65216)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216) command document too large
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216) Traceback (most recent call last):
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 222, in run
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     self.update_content(metadata_files, url)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 486, in update_content
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     self.download_rpms(metadata_files, rpms_to_download, url)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 664, in download_rpms
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     unit = self.add_rpm_unit(metadata_files, unit)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 615, in add_rpm_unit
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     unit.save()
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib/python2.7/site-packages/mongoengine/document.py", line 324, in save
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     object_id = collection.save(doc, **write_concern)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib64/python2.7/site-packages/pymongo/collection.py", line 2180, in save
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     check_keys, False, manipulate, write_concern)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib64/python2.7/site-packages/pymongo/collection.py", line 709, in _update
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     codec_options=self.codec_options).copy()
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib64/python2.7/site-packages/pymongo/pool.py", line 216, in command
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     self._raise_connection_failure(error)
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)   File "/usr/lib64/python2.7/site-packages/pymongo/pool.py", line 343, in _raise_connection_failure
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216)     raise error
Dec 22 11:58:03 katello01 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (2711-65216) DocumentTooLarge: command document too large
Dec 22 11:58:03 katello01 pulp: py.warnings:WARNING: (2711-65216) /usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py:804: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
Dec 22 11:58:03 katello01 pulp: py.warnings:WARNING: (2711-65216)   sync_result_collection.save(sync_result)
Dec 22 11:58:03 katello01 pulp: py.warnings:WARNING: (2711-65216)
Dec 22 11:58:03 katello01 pulp: pulp.server.event.http:INFO: (2711-65216) {"call_report": {"exception": null, "task_type": "pulp.server.managers.repo.sync.sync", "_href": "/pulp/api/v2/tasks/f3dde23f-7d50-4051-8b2a-cbde027c2420/", "task_id": "f3dde23f-7d50-4051-8b2a-cbde027c2420", "tags": ["pulp:repository:myorg-foreman-foreman_releases_latest_x86_64", "pulp:action:sync"], "finish_time": null, "_ns": "task_status", "start_time": "2016-12-22T10:57:38Z", "traceback": null, "spawned_tasks": [], "progress_report": {"yum_importer": {"content": {"size_total": 81851544, "items_left": 314, "items_total": 314, "state": "FAILED", "size_left": 81851544, "details": {"rpm_total": 314, "rpm_done": 0, "drpm_total": 0, "drpm_done": 0}, "error": "command document too large", "error_details": []}, "comps": {"state": "NOT_STARTED"}, "purge_duplicates": {"state": "NOT_STARTED"}, "distribution": {"items_total": 0, "state": "NOT_STARTED", "error_details": [], "items_left": 0}, "errata": {"state": "NOT_STARTED"}, "metadata": {"state": "FINISHED"}}}, "state": "running", "worker_name": "reserved_resource_worker-0@katello01.ipa.myorg.com", "result": null, "error": null, "_id": {"$oid": "585bb1a2df68df722220b0b8"}, "id": "585bb1a2df68df722220b0b8"}, "event_type": "repo.sync.finish", "payload": {"importer_id": "yum_importer", "exception": null, "repo_id": "myorg-foreman-foreman_releases_latest_x86_64", "traceback": null, "started": "2016-12-22T10:57:38Z", "_ns": "repo_sync_results", "completed": "2016-12-22T10:58:03Z", "importer_type_id": "yum_importer", "error_message": null, "summary": {"content": {"state": "FAILED"}, "comps": {"state": "NOT_STARTED"}, "purge_duplicates": {"state": "NOT_STARTED"}, "distribution": {"state": "NOT_STARTED"}, "errata": {"state": "NOT_STARTED"}, "metadata": {"state": "FINISHED"}}, "added_count": 0, "result": "failed", "updated_count": 140, "details": {"content": {"size_total": 81851544, "items_left": 314, "items_total": 314, "state": "FAILED", "size_left": 81851544, "details": {"rpm_total": 314, "rpm_done": 0, "drpm_t
Dec 22 11:58:03 katello01 pulp: pulp.server.event.http:INFO: (2711-65216) otal": 0, "drpm_done": 0}, "error": "command document too large", "error_details": []}, "comps": {"state": "NOT_STARTED"}, "purge_duplicates": {"state": "NOT_STARTED"}, "distribution": {"items_total": 0, "state": "NOT_STARTED", "error_details": [], "items_left": 0}, "errata": {"state": "NOT_STARTED"}, "metadata": {"state": "FINISHED"}}, "id": "585bb1bb2f92650a979672aa", "removed_count": 0}}
Dec 22 11:58:03 katello01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): katello01.ipa.myorg.com
Dec 22 11:58:03 katello01 pulp: pulp.server.async.tasks:INFO: Task failed : [f3dde23f-7d50-4051-8b2a-cbde027c2420]
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216) Task pulp.server.managers.repo.sync.sync[f3dde23f-7d50-4051-8b2a-cbde027c2420] raised unexpected: PulpExecutionException('Importer indicated a failed response',)
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216) Traceback (most recent call last):
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)     R = retval = fun(*args, **kwargs)
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 484, in __call__
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)     return super(Task, self).__call__(*args, **kwargs)
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in __call__
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)     return super(PulpTask, self).__call__(*args, **kwargs)
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)     return self.run(*args, **kwargs)
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 810, in sync
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216)     raise pulp_exceptions.PulpExecutionException(_('Importer indicated a failed response'))
Dec 22 11:58:03 katello01 pulp: celery.worker.job:ERROR: (1145-65216) PulpExecutionException: Importer indicated a failed response
Dec 22 11:58:03 katello01 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[079f2a46-9d4f-4def-887b-470a8919b8fa] succeeded in 0.00792156299997s: None

To troubleshoot I tried syncing "releases/latest/el7/x86_64", "releases/1.13/el7/x86_64", "releases/1.14/el7/x86_64" and "releases/latest/f24/x86_64" all with the same error.
On the other hand I successfully synchronized "releases/1.12/el7/x86_64" and "plugins/latest/el7/x86_64" (as well as many non foreman repos).

This was already happening with katello 3.2 and now with 3.2.2.

History

#1 Updated by Pascal Pascher over 5 years ago

Seems to be known and now worked on by pulp: https://pulp.plan.io/issues/723

#2 Updated by Justin Sherrill over 5 years ago

  • Category set to Repositories
  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

This is caused by a pulp issue filed here: https://pulp.plan.io/issues/723

Closing this as there is nothing katello can do.

#3 Updated by Johannes Hirte about 5 years ago

This is fixed in pulp upstream now. Any chance we can expect this as bugfix in the current katello release?

Also available in: Atom PDF