Project

General

Profile

Bug #17916

Content view filter cannot distinguish between multiple packages with the same version but different release number

Added by Justin Sherrill over 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1395642

Description of problem:
In case there are multiple packages of the same version but different package release version in a repository and if this repository is included in a content view with "rpm version filter" they are not being properly filtered and all the packages are being included in the cv regardless their release version.

Ex:
List of packages in repo:
test_rpm-0.0.1-1.el7.noarch.rpm
test_rpm-0.0.1-10.el7.noarch.rpm
test_rpm-0.0.1-2.el7.noarch.rpm
test_rpm-0.0.1-4.el7.noarch.rpm
test_rpm-0.0.1-5.el7.noarch.rpm

Filters:
content-view filter list --organization-id 1 --content-view-id 4
----------|------------|------|----------
FILTER ID | NAME | TYPE | INCLUSION
----------|------------|------|----------
1 | includepkg | rpm | true
----------|------------|------|----------

content-view filter rule list --organization-id 1 --content-view-id 4 --content-view-filter-id 1
--------|-----------|-----------|--------------|-----------------|-----------------|-----------|------------|---------
RULE ID | FILTER ID | NAME | VERSION | MINIMUM VERSION | MAXIMUM VERSION | ERRATA ID | START DATE | END DATE
--------|-----------|-----------|--------------|-----------------|-----------------|-----------|------------|---------
4 | 1 | test_rpm | 0.0.1-4.el7* | | | | |
--------|-----------|-----------|--------------|-----------------|-----------------|-----------|------------|---------

With this setup, all the packages listed above will be included in the newly published CV

Version-Release number of selected component (if applicable):
6.2.x (6.1.x as well)

How reproducible:
1) Create product, repository and some fake packages with same version but different release versions (see example above)
2) Create content view, add the repo from step #1 into it and create filter based on the example above
3) Publish the CV and check results

Actual results:
All packages are being included

Expected results:
Only specific version(s) should be included


Related issues

Is duplicate of Katello - Bug #17486: Content view filter version "Equals To" matching all packages instead of only one.Duplicate2016-11-25

Associated revisions

Revision bafd8b82 (diff)
Added by Justin Sherrill over 2 years ago

Fixes #17916 - properly handle pkg filter equals clause

This resolves an issue where package filter version matching
was improperly matching against all rpms with the same version even
if a release was specified

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Justin Sherrill
  • Pull request https://github.com/Katello/katello/pull/6521 added

#2 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 188
  • Difficulty set to easy

#3 Updated by Brad Buckingham over 2 years ago

  • Target version set to 151

#4 Updated by Justin Sherrill over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Eric Helms almost 2 years ago

  • Is duplicate of Bug #17486: Content view filter version "Equals To" matching all packages instead of only one. added

Also available in: Atom PDF