Project

General

Profile

Bug #17922

List of repositories not updated after creating new repo

Added by Daniel Lobato Garcia over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

To reproduce:

1. Go to Content > Products
2. Choose a product
3. See the list of repositories.
4. Create a new repository by clicking on 'New repository'
5. Submit the new repository form.
6. The list of repositories remains the same as if no repo had been created.
7. You need to refresh the browser or go to another page and come back to see the new repo.

History

#1 Updated by Daniel Lobato Garcia over 5 years ago

Similar behavior can be seen like this:

1. Under 'Content > Content views', choose a content view
2. Go to the puppet modules tab
3. Click on add new module
4. Choose a module and submit it.
5. The list isn't updated until you refresh the page.

#2 Updated by Justin Sherrill over 5 years ago

  • Assignee set to Walden Raines
  • Legacy Backlogs Release (now unused) set to 188

#3 Updated by Walden Raines over 5 years ago

  • Target version set to 154

#4 Updated by Brad Buckingham over 5 years ago

I've seen similar with:

- remove content view
- issue: does not remove it from the list
- workaround: reload page

- create content view
- issue: does not add it to the list
- workaround: reload page

#7 Updated by Walden Raines over 5 years ago

When http://projects.theforeman.org/issues/18079 is fixed this issue will seem to go away but will only be hidden. I will continue to track the katello side changes in this bug for when we reenable the table cache.

#8 Updated by Walden Raines over 5 years ago

  • Target version changed from 154 to 161

#9 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 188 to 211

#10 Updated by Walden Raines over 5 years ago

  • Status changed from New to Assigned

#11 Updated by Walden Raines about 5 years ago

  • Target version changed from 161 to 166

#12 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 211 to 114

#13 Updated by Walden Raines about 5 years ago

  • Status changed from Assigned to Duplicate

Duplicate of #18485.

#15 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) deleted (114)

#16 Updated by Justin Sherrill almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF