Project

General

Profile

Bug #17930

unable to add a puppet module from GUI

Added by Brad Buckingham over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1397764

Description of problem:
Unable to add a puppet module to content view from GUI when there are so many puppet modules with more than one version of the same module

Version-Release number of selected component (if applicable):
6.2.4 and 3.8

How reproducible:
Always

Steps to Reproduce:
1.sync the puppet forge
2.add 10 to 15 versions of same module for some modules
3.create a content view and try adding a puppet module(In my case the cu was trying to add razoredges network module)
4.initially the module would appear and while selecting the version it would again take you back to the modules that have the search content in their summary.
5.if there are somany modules in the repo then we will not find the complete list in the page and there is no option to go to the second page.
6.as the required module isn't available we are not able to add it.

Actual results:

the required module isn't available

Expected results:

we should be able to select the next page and select the required module


Related issues

Has duplicate Katello - Bug #18794: Not all puppet modules showing up when adding them to a content viewDuplicate2017-03-03
Is duplicate of Katello - Bug #16309: Cannot add Puppet module to content view if there are too many to choose fromDuplicate2016-08-25

Associated revisions

Revision 3a35c40c (diff)
Added by John Mitsch over 5 years ago

Fixes #17930 - fix pagination in CV available puppet module versions

History

#1 Updated by Brad Buckingham over 5 years ago

  • Subject changed from unable to add a puppet module from GUI to unable to add a puppet module from GUI
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by John Mitsch over 5 years ago

  • Assignee set to John Mitsch
  • Target version set to 169

#3 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Legacy Backlogs Release (now unused) deleted (114)
  • Pull request https://github.com/Katello/katello/pull/6647 added

#4 Updated by John Mitsch over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) set to 226

#6 Updated by John Mitsch over 5 years ago

  • Has duplicate Bug #18794: Not all puppet modules showing up when adding them to a content view added

#7 Updated by Jason Nance about 5 years ago

  • Is duplicate of Bug #16309: Cannot add Puppet module to content view if there are too many to choose from added

Also available in: Atom PDF