Project

General

Profile

Bug #17948

Yum dependency problem upgrading from Katello 3.1 to 3.2

Added by Juan Pablo Lorier over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Both in REHL 7.3 and Centos 7.3 I needed to manually remove the package tfm-rubygem-tire (yum remove tfm-rubygem-tire) as yum update fails claiming tfm-runtime obsolets the package

History

#1 Updated by Justin Sherrill over 5 years ago

  • Category set to Installer
  • Assignee set to Justin Sherrill

#2 Updated by Eric Helms about 5 years ago

Can you give us the full yum output from the upgrade when that error is hit?

#3 Updated by Eric Helms about 5 years ago

  • Status changed from New to Need more information

#4 Updated by Eric Helms about 5 years ago

  • Status changed from Need more information to Needs design

#5 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

#6 Updated by Juan Pablo Lorier about 5 years ago

Eric Helms wrote:

Can you give us the full yum output from the upgrade when that error is hit?

Sorry Y didn't reply in time. I'm not able to get you now an output, but the output only said that the package was obsoleted by tfm-runtime and failed to resolve dependencies. Only by manually removing the package (which didn't have any dependencies) solved the problem.
Regards

#7 Updated by Justin Sherrill about 5 years ago

  • Status changed from Needs design to Rejected

Since there is a workaround and this is the only report we've gotten, we'll go ahead and close this.

Also available in: Atom PDF