Bug #17979

nokogiri 1.7 was released which requires ruby >= 2.1

Added by Tomer Brisker over 1 year ago. Updated 9 days ago.

Status:Closed
Priority:Normal
Assignee:Tomer Brisker
Category:Packaging
Target version:1.13.4
Difficulty: Team Backlog:
Triaged: Fixed in Releases:
Bugzilla link: Found in Releases:
Pull request:https://github.com/theforeman/foreman/pull/4166

Description

This causes CI on ruby 2.0 to fail.


Related issues

Related to Foreman - Tracker #15954: Drop Ruby 2.0 support Closed 08/03/2016

Associated revisions

Revision 7c7a2c1f
Added by Tomer Brisker over 1 year ago

Fixes #17979 - Pin nokogiri to last version supporting ruby 2.0

Revision 810e1a81
Added by Dominic Cleal over 1 year ago

fixes #17979 - pin nokogiri for Ruby 2.0 compatibility

Revision 546dfabd
Added by Dominic Cleal over 1 year ago

fixes #17979 - pin nokogiri for Ruby 2.0 compatibility

(cherry picked from commit 810e1a8190ee8b17208baf34a1cc3d7046166b6a)

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Tomer Brisker
  • Pull request https://github.com/theforeman/foreman/pull/4166 added

#2 Updated by Tomer Brisker over 1 year ago

#3 Updated by Dominic Cleal over 1 year ago

  • Legacy Backlogs Release (now unused) set to 213

#4 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version set to 169

#6 Updated by Brad Buckingham over 1 year ago

  • Target version deleted (169)

#7 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version set to 1.11.0

Also available in: Atom PDF